3
$\begingroup$

So I am making plants for a game and sometimes when I use Import Images as Planes, it has this random line at the top. I've done numerous test to see if my images were the problem, but every time I reimport the file it still has the line. I tried creating a new image, getting rid of other layers, erasing the background numerous times and it still has it. There are some images though that do not have this problem, but it seems to occur most of the time. If anyone could help, that would be more than wonderful.

enter image description here

The top has the random line in it.

enter image description here

The line is not in this image.

$\endgroup$
3
  • $\begingroup$ Suggest posting / linking original images. Can then at least see if same behaviour occurs... oh and welcome to bse. $\endgroup$ – batFINGER Aug 8 '17 at 6:40
  • 1
    $\begingroup$ Set ithe image texture to Clip rather than Repeat - looks like this is simply bleeding from the bottom of the image as it wraps to the next repeat. Similar to blender.stackexchange.com/q/45725/29586 $\endgroup$ – Rich Sedman Aug 8 '17 at 7:05
  • $\begingroup$ @RichSedman can I suggest you make your comment an answer? This problem is affecting multiple users (the one you link, also this one from 2015 blender.stackexchange.com/questions/39238/…) that use "Import as a plane". They might come across this question via search engines and benefit from your tip. $\endgroup$ – Nicola Sap Aug 8 '17 at 9:12
5
$\begingroup$

Image textures employ interpolation to blend pixels into the neighbouring space so as to smooth the image rather than provide a hard pixelated effect. With the image set to Repeat there is actually a copy of the image just beyond the image borders. In your case the image against the opposite edge is butter right up against the edge and so the interpolation is causing it to 'bleed' across te border - the bottom of your grass image is bleeding into the top.

To resolve this, simply set the image to Clip rather than Repeat.

The option is located under the "Texture" panel:

  • If you're using Cycles

    enter image description here

  • If you're using Blender render

    enter image description here

$\endgroup$
1
  • $\begingroup$ Glad to help. If this resolves the problem, please 'Accept' the answer (click the 'tick' button alongside the answer). This will make it easier to find for others experiencing the same issue (and you'll also gain some reputation points yourself). $\endgroup$ – Rich Sedman Aug 12 '17 at 5:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.