0
$\begingroup$

I'm working on animating a logo that was created for me in photoshop which is just some text and two different colors that cut across the text simulating light. In animating the logo I decided to place two lights which I would toggle on during the animation. However, as expected, light blends colors and in this case red and white light make pink. Is it possible to not allow the light to blend or is there a better way to approach this?

Image is what is desired to animate/duplicateenter image description here

$\endgroup$
  • 1
    $\begingroup$ What do you mean by "toggle on during the animation"? Are lights supposed to be flashing on and off? Are the lights going to be moving around as if it were a searchlight? Could you please make your question easier to interpret. $\endgroup$ – masterj2001 Aug 8 '17 at 2:04
  • $\begingroup$ My apologizes, at a certain keyframe X I am changing the energy value of the white light, and then later at keyframe Y I am doing the same thing to the red light. The lights are fixed at a position in the lower right corner to obtain the desired cross cutting effect. $\endgroup$ – Matt R Aug 8 '17 at 2:14
  • $\begingroup$ If you want well defined edges between colors wouldn't it be much easier to just use geometry instead? $\endgroup$ – Duarte Farrajota Ramos Aug 8 '17 at 2:23
  • $\begingroup$ Would I still be able to animate it shooting from the bottom right out across the text? It'd be quick and subtle, i'm just wondering. I don't really know the best way to approach something like this $\endgroup$ – Matt R Aug 8 '17 at 2:29
0
$\begingroup$

Ok, so this is going to be pretty extensive and difficult to explain through text and images but I'll do my best.

Make sure you're in cycles render

Begin by deleting everything in your scene, add in your text and center it enter image description here

Now lets create our layers, name layer 1 and layer 2 (name choice is up to you). Make the first layer associated with layer 1 and the second layer with layer 2 enter image description here

Add a camera into your scene, press 5 and then 7 to enter top down orthographic view, and then Ctrl+Alt+0 to move the camera to your current perspective enter image description here

(you can then modify how close the camera is to the text with g and then z, or using the axis arrows).

Move to the second layer and create 3 planes (one will be the red light, white light and colour of the text) Make sure that these three planes are spaced out along the z-axis to ensure that they aren't intersecting. From here, enter edit mode and manipulate the vertices to match the shape you're trying to create for the lights.

You should have something that looks like this: enter image description here

Select one of the planes that is representing a light, select the object settings and under Cycles Settings deselect diffuse. Do this for both planes representing lights.

Go into the node editor, select one of the planes representing a light and create this node setup: enter image description here

Once you have done this for both light planes, create a similar node setup for the plane that will represent the text's colour. Should look like this: enter image description here

(The emission colour will effect the text's colour)

Tick the transparent option, shift select both layers and hit render. enter image description here

After rendering go into the compositor and create this setup: enter image description here

This is pretty much the final result, now all you need to do is animate the colour ramps to emulate the lights, crank the white value closer to the black and that will remove your issue of the colours blending.

enter image description here

Hope this helps and resolved your issue, sorry if any of this is hard to understand. If so, just let me know and I'll do my best to reiterate what I was trying to say. I will also attach the .blend file so that you can dissect what I did if you get stuck.

$\endgroup$
  • $\begingroup$ After more time than I wish learning Blender took, I've almost got this. The last two questions I have are that I'm trying to fade in the text now at the start of the animation. I've got a mix shader that i'm running a Diffuse and Transparent too and animating keying the transparency factor. But that's messing with my background color, and not showing the text (though I've selected it to be rendered; only the "lights" are rendering). Any ideas? $\endgroup$ – Matt R Aug 24 '17 at 1:14
  • $\begingroup$ If you have a node setup like so: imgur.com/MvNLx5w for the text then you should be all good. Works for me when I render it. Just double check that you have both layers selected. If you upload a version of your .blend file I will happily check it out to find a solution. blend-exchange.giantcowfilms.com $\endgroup$ – masterj2001 Aug 26 '17 at 0:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.