2
$\begingroup$

This happened to me some times in the past. When a fluid interacts with an obstacle, it might appear some jagged pattern in the sides of fluid stream. As seen in the image below, increasing the fluid resolution doesn't fix the problem.

enter image description here

500 & 750 fluid resolution.

What is causing this behavior?

My setup is pretty default and I think this is a common issue. Anyway here is some data:

Domain:

  • The fluid uses the "Honey" preset.
  • Surface Smoothing is set to 0.5
  • Remove Air Bubbles is disabled.
  • Everythig else is Default.

Obstacle:

  • The Obstacle object is set to Shell.
  • Slip Type is Partial Slip with 0.2 Amount.
$\endgroup$
  • $\begingroup$ Did you find a solution? I'm having a similar behavior when fluid drops on my object. I have enabled things like subdivision x2, generate particals x0.005 And export animated mesh. Cannot seem to rid the crazy jagged edges. Each recalculate of the fluid takes ages so quick fixing isn't going to be by changing values a heap of times til it's right $\endgroup$ – ToxsickcitY Apr 18 '18 at 0:02
  • $\begingroup$ I don't quite remember, but I think I did not find a solution. You can use a Decimate an then a Subdivision Surface to soften the effect. But I think that we'll need to wait to Mantaflow or the FLIP addon to get decent edges. $\endgroup$ – Antonio Buch Apr 20 '18 at 11:54
1
$\begingroup$

I found a solution for my instance it appears to have been the export mesh option on the obstruction.

It was causing all those jagged edges and simply disabled that and choose partial slip and turned off subsurface on the domain.

I too am waiting for flips released next month but they want 76$ usd :( Look up on Facebook flips fluid addon

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.