1
$\begingroup$

I am doing an animation with a camera to add 3D elements to it (don't really know what it is called) enter image description here As you can see in the picture above, i am trying to use nodes to assemble my shadow, object and background for the final render, but for my shadow, some of the plane is still visible... I tried using a "Dilate/Erate" node to mask the plane but it ends up also hiding the shadow.

Do you guys have any idea on how I can fix this? Thank you

$\endgroup$

marked as duplicate by cegaton, Denis, Duarte Farrajota Ramos, Ray Mairlot, VRM Aug 7 '17 at 2:39

This question was marked as an exact duplicate of an existing question.

  • 4
    $\begingroup$ Why are you doing such a thing? in your previous question you were given a solution using alpha over. Please elaborate on why that didn't work. $\endgroup$ – cegaton Aug 5 '17 at 14:47
2
$\begingroup$

In my opinion you are overcomplicating things.

Since you are using the new shadow catcher feature available in 2.78.5 you don't need to do much.

Set the plane that will receive the shadow, and set it to be a shadow catcher in Cycles Settings> Ray Visibility.

enter image description here

The rendered image will have the shadow and the rest of the plane will be transparent:

enter image description here

Then just overlay the rendered image onto your background using Alpha Over:

enter image description here

$\endgroup$
  • $\begingroup$ That was the original answer for your original question. Please don't duplicate your posts. If the answers are not working for you use comments or edit your original post. $\endgroup$ – cegaton Aug 5 '17 at 21:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.