0
$\begingroup$

So I made this cushion but it has this weird clipping or shading on the cushion part.

Here it is without subdivision smoothness and also with it. Any ideas how I can begin fixing this?

enter image description here

enter image description here

This was after i went through and individually deleted each double face

This was after i went through and deleted any double faces individually. Not sure why remove doubles didnt catch them. Still doesnt look right.

$\endgroup$
4
  • 1
    $\begingroup$ And before you ask i already removed doubles so its not a double mesh issue. $\endgroup$
    – Wolfgang
    Aug 4 '17 at 6:35
  • $\begingroup$ There shouldn't be necessarily doubles to make the mesh look wrong. Start with recalculating normals, see blender.stackexchange.com/q/3606/1245. Then likely it is non-manifold where those grey parts seen trough cushion are faces of the bottom part not connected to anything. Some rebuilding and cleaning work will be required to change that mesh $\endgroup$
    – Mr Zak
    Aug 4 '17 at 10:29
  • $\begingroup$ It does look like z-fighting due to duplicated geometry. $\endgroup$
    – user1853
    Aug 4 '17 at 14:16
  • $\begingroup$ Please use blend-exchange to share files on this site. $\endgroup$
    – Mr Zak
    Aug 4 '17 at 19:08
2
$\begingroup$

This definitely looks like two meshes. May be a duplicate, hidden in Viewport, but visible while rendering? If you can't solve the issue, consider uploading your blend file.

Edit: After checking your file, it's clear that overlapping faces are the reason for your problems. Look at the screenshots, I raised some part of your mesh. You need to remodel your mesh, to avoid intersecting faces.

enter image description here enter image description here

$\endgroup$
4
  • $\begingroup$ How do I upload my file? I tried the normals thing and it didnt work. And I went in and removed doubles again and says 0 vertices removed so Im still having the issue. $\endgroup$
    – Wolfgang
    Aug 4 '17 at 17:55
  • 1
    $\begingroup$ I uploaded my file to this site. we.tl/i0FoR0K08O thanks! $\endgroup$
    – Wolfgang
    Aug 4 '17 at 18:04
  • $\begingroup$ So I went through and started deleting individual faces and there were doubles. Not sure why it didnt catch it automatically. I went through the whole top layer and removed all the double faces but it still looks wrong. $\endgroup$
    – Wolfgang
    Aug 4 '17 at 18:29
  • $\begingroup$ I edited my answer after checking your file. $\endgroup$
    – Grimm
    Aug 4 '17 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.