2
$\begingroup$

Basically, I applied my textures by taking each individual object, unwrapping it in the uv editor, then opening up an image in the uv editor and it would apply the texture in the 3D editor. However, when I render my project none of the textures appear and everything looks odd. I don't know how to set up the images properly with the bee.

For example, here's the uv layout image for the bee's Cube.001:

How do I get that applied properly to the Cube.001 in my project?

Here is the file for reference

Everything appears purple if the images aren't there and I don't know how to fix that either.

$\endgroup$
3
$\begingroup$

Pink means the image for the texture is missing. Make sure the image queenBee1.png is where blender thinks it is (which is in a directory called queenbee next to the .blend).

Unfortunately the textures are not included in the .blend by default (you must pack them), so if there are problems beyond this I can't tell what they are.

To pack all external textures, press Pack into .blend in Info > Header > File > External data.
I noticed that you changed the info panel (at the top of the window be default) into an image editor. You can change it back by clicking on the icon on the left and selecting Info:

enter image description here

There is also a operator in the External data submenu called Report missing files which will help you find what files are missing (if any).


If you have the image location right but it's still saying can't load image in Textures > Image and not appearing, some other common issues are:

  • If the location was set incorrectly but has since been corrected, try reloading it by pressing the arrows icon:

    enter image description here

  • Make sure the texture is enabled:

    enter image description here

  • Make sure the texture is allowed to influence the color of the material in Textures > Influence:

    enter image description here


The reason everything looks odd is because the body mesh is duplicated, resulting in overlapping faces and z-fighting. If you select what appears to be the main body and press G to move it you'll see that there are actually two:

enter image description here

To fix it, just delete one of them. Note that one of the duplicates does not have UV selected for the mapping coordinates, so if you delete the other one make sure to set the coordinates to UV in Textures > Mapping:

$\endgroup$
  • $\begingroup$ Wonderful, that fixed all the odd looking stuff. My last question is, how exactly do I go about properly adding the textures? I've noticed if I press F12 the textures don't actually render. Thanks again! $\endgroup$ – Alexander Khaos Greenstein Apr 19 '14 at 8:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.