2
$\begingroup$

I have nothing but all factory Defaults and a simple cube....(Typical Start-up with a changed theme.)

1 Month ago, I installed Blender 2.78c as an upgrade from 2.77. I had this issue then too. I was able to use GPU for renders until I installed 2.78c before. Somehow I found a forum that had a working fix. It worked! :D but then later, I installed Blender 2.79 and lost the OpenCL option in the user pref. but I was still able to select it in the properties window under render even though it was grayed out.

It seemed to work okay, slower than before but faster still than CPU. Then I installed Sensei Format and then everything went to crap. CPU Render times Shot through the roof and my computer slowed way down just to use Sensei. I uninstalled Sensei and everything went back to normal except now with 2.79 I lost the ability to choose GPU compute under render in the properties panel and still didn't have the OpenCL option in user pref.

So today I uninstalled Blender completely and wiped the computer of anything blender. Updated my graphics driver (Which needed to anyway)then reinstalled Blender 2.79. No good Nothing worked. Only CPU and it took 7.5 hours to render 35% of a scene containing a cube with a glass shader, a UV Sphere with a glossy shader and a basic sky texture. No way that should have taken that long with 8gb of RAM and a duo-core proc. So I did another complete blender wipe and reinstalled Blender 2.78c. That same scene rendered in 3.5 min. with CPU. So obviously this reinstall was good. Better CPU render time and I had the option for the OpenCL back in the user pref. However, when I select GPU (It is no longer grayed out) it gets stuck on loading the kernels and stays at 0% for 30 min before finally it crashes the computer. This is where my problems lay.

UPDATE: I have discovered that the reason Blender wont render on GPU is because when it starts, the Loading of Kernels drives my Physical Memory into the ground. Is there a way to fix that?

Graphics Card Specs:

Card name: AMD Radeon HD 7480D

   Manufacturer: Advanced Micro Devices, Inc.
      Chip type: AMD Radeon Graphics Processor (0x9993)
       DAC type: Internal DAC(400MHz)
     Device Key: Enum\PCI\VEN_1002&DEV_9993&SUBSYS_1850103C&REV_00

 Display Memory: 4039 MB

Dedicated Memory: 480 MB

  Shared Memory: 3559 MB
   Current Mode: 1920 x 1080 (32 bit) (60Hz)
   Monitor Name: Dell E2416H(Analog)
  Monitor Model: DELL E2416H
     Monitor Id: DELA0C9
    Native Mode: 1920 x 1080(p) (60.000Hz)
    Output Type: HD15

    Driver Name:

aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll

Driver File Version: 8.17.0010.1404 (English)

 Driver Version: 15.201.2401.1001

    DDI Version: 11

   Driver Model: WDDM 1.1

Driver Attributes: Final Retail

Driver Date/Size: 2/17/2016 10:36:30, 1469808 bytes

    WHQL Logo'd: Yes

WHQL Date Stamp: 

Device Identifier: {D7B71EE2-DAD3-11CF-F076-5A38BEC2C535}

      Vendor ID: 0x1002

      Device ID: 0x9993

      SubSys ID: 0x1850103C

    Revision ID: 0x0000

Driver Strong Name:

oem48.inf:ATI.Mfg.NTamd64.6.1:ati2mtag_Trinity_Desktop:15.201.2401.1001:pci\ven_1002&dev_9993&subsys_1850103c

 Rank Of Driver: 00E60001

    Video Accel: ModeMPEG2_A ModeMPEG2_C 

Deinterlace Caps:

{6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive

                 {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch

                 {5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY 
                 {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                 {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch 
                 {5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY 
                 {5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(YV12,0x32315659) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
                 {3C5323C1-6FB7-44F5-9081-056BF2EE449D}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                 {552C0DAD-CCBC-420B-83C8-74943CF9F1A6}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                 {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                 {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch 
                 {5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY 
                 {5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(IMC1,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
                 {5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(IMC2,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
                 {5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(IMC3,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
                 {5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(IMC4,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
                 {5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(S340,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
                 {5A54A0C9-C7EC-4BD9-8EDE-F3C75DC4393B}: Format(In/Out)=(S342,UNKNOWN) Frames(Prev/Fwd/Back)=(0,0,0) Caps=
   D3D9 Overlay: Not Supported
        DXVA-HD: Not Supported
   DDraw Status: Enabled
     D3D Status: Enabled
     AGP Status: Enabled

Computer Specs:

Windows 7 Professional 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_ldr.170512-0600)

       Language: English (Regional Setting: English)

System Manufacturer: Hewlett-Packard

   System Model: HP Compaq Pro 6305 SFF

           BIOS: Default System BIOS

      Processor: AMD A4-5300B APU with Radeon(tm) HD Graphics    (2 CPUs), ~3.4GHz

Memory: 8192MB RAM

Available OS Memory: 7630MB RAM

      Page File: 3577MB used, 11681MB available

    Windows Dir: C:\Windows

DirectX Version: DirectX 11

DX Setup Parameters: Not found

User DPI Setting: Using System DPI

System DPI Setting: 96 DPI (100 percent)

DWM DPI Scaling: Disabled

 DxDiag Version: 6.01.7601.17514 32bit Unicode

I am using Blender 2.78c (Downgraded From 2.79 with Sensei Format). Sorry for all the information.

$\endgroup$
  • $\begingroup$ I found some release notes for 2.78c and the picture showed the same Card I use with the same "Scrapper" in the Device window. That user used GPU Rendering with absolutely no problems. Why would I be having these issues? $\endgroup$ – Travis Trapani Aug 4 '17 at 8:08
  • $\begingroup$ UPDATE: I have discovered that the reason Blender wont render on GPU is because when it starts, the Loading of Kernels drives my Physical Memory into the ground. Is there a way to fix that? $\endgroup$ – Travis Trapani Aug 4 '17 at 10:38
1
$\begingroup$

I had a similar issue, I'd set GPU render, it would say "loading render kernel (this may take a few minutes) and after a few seconds, crash to desktop with no error.

I'm not an expert so this may be off but my understanding of how blender works is, if you want to render on GPU, it has to compile that kernel and it saves the info in a folder, in windows that folder is something like:

C:\Users\YourName\AppData\Roaming\Blender Foundation\Blender\2.78\cache\kernels

If you have existing kernels in there it may try to use them. So step 1 is, if you ever install a different version of blender (or try to reinstall the current one) then you need to clean out this folder or maybe just delete the entire Blender Foundation folder if you want to ensure a clean install.

For me, changing the geometry or materials or whatever didn't seem to help, and the video card was pretty good (R9) and the ram is good (32 gigs) so I figured it was more of an issue with blender not communicating with the GPU properly, as opposed to a lack of horsepower.

So I did a clean reinstall, removing the old blender folder and searching for registry stuff (there isn't any really)... and unlike before where I'd experimented with 2.8 and 2.79, I just used the recommended version (2.8c) and used the windows 64-bit .MSI installer.

I also updated my video card driver. I'd tried that once but I had a slightly newer version so I did it again. Rebooted.

I then checked preferences-system and checked the option to enable GPU rendering... and in the past, that had something about OpenCL and listed my card, but this time it listed something I hadn't seen before, "Hawaii"... I googled and found out that's the codename for my video card's chipset or whatever. So it was recognizing my card differently than in the past.

My render using GPU worked fine this time. So I guess tl;dr is
• delete C:\Users\YourName\AppData\Roaming\Blender Foundation\
• Update video card driver
• Install the latest non-alpha or non-beta version of blender
• Confirm your card is recognized in preferences, as you enable GPU render.

And lastly, even though I said the issue wasn't a lack of horsepower, I suspect 8 gigs might be a bit low for rendering? I looked it up and your CPU can handle 32. The ram isn't as cheap as it used to be but IMO you shouldn't try to run without 16.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.