0
$\begingroup$

So, I made this outdoor project and I'm trying to blur the grass that peaks in the foreground, but controlling the depth of field and/or focus of the camera doesn't help me at all. Actual render

enter image description here

$\endgroup$
  • $\begingroup$ Change the viewport shading type from Material to Rendered to see the results. $\endgroup$ – Paul Gonet Aug 3 '17 at 11:22
  • $\begingroup$ The upper picture is the rendered image $\endgroup$ – Christian Triolo Aug 3 '17 at 12:16
  • 1
    $\begingroup$ The Size option is set to 0, which means no bluring afaik if using Radius mode for aperture. Either increase it or change it to F-Stop and decrease (by default 5.6) $\endgroup$ – Mr Zak Aug 3 '17 at 12:25
1
$\begingroup$

Final:

Final

Overview:

Focal point:

Use Empty object as a Focus to better control DOF. Just place it where you want to have sharp spot and it's done.

Matching Viewport Preview with Render:

To match both views you need to use F-stop values for both Aperture and Viewport also you need to check High Quality. And lastly turn on Depth Of Field under Shading tab (N to open/close Properties Region).

Notes:

Check your Focal Length and F-stop Values as they are crucial for DOF. Lower F-stop value will give you shallow DOF (more blur), higher Focal Length will also give you more blur but it will distort perspective.

$\endgroup$
  • $\begingroup$ It worked, thanks a lot! Had problems with a simple empty, so had to create an empty cube, make the borders coincide with the shape of the building, excluding the grass, played a little with tweaking and obtained what I wanted. Really really helpful! :) $\endgroup$ – Christian Triolo Aug 3 '17 at 16:14
  • $\begingroup$ @ChristianTriolo To add Empty press Shift+A > Empty > Plain Axes $\endgroup$ – cgslav Aug 3 '17 at 17:07
  • $\begingroup$ The depth of field checkbox is grayed out under shading for 2.79. What should I do to fix that? $\endgroup$ – DROP TABLE names Jun 10 at 15:12
  • $\begingroup$ @Lincoln are you using Cycles renderer and/or have active camera in the scene? $\endgroup$ – cgslav Jun 11 at 18:19
  • $\begingroup$ @cgslav, sorry, I fixed it. I forgot to select the camera. My bad. $\endgroup$ – DROP TABLE names Jun 11 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.