9
$\begingroup$

The light particles I need to fix

How can I get rid of those little white dots? I am using Blender 2.70a.

$\endgroup$
13
$\begingroup$

This is noise, which will happen in complex scenes without enough samples.

Aside from increasing the number of samples, here are some other things you can try:

  • Enable Multiple Importance Sample for the lamp in Properties > Object Data > Lamp:

    enter image description here

  • Adjust the Clamp in Properties > Render > Sampling. Note that as of 2.70 indirect samples can be clamped separately from direct samples.

  • Increase the filter glossy option (also in Render > Light Paths) if you have rough glossy materials.

There are also some tricks you might be able to do with your materials, but it's hard to say what without looking at your file.


Also see these related questions:

And the wiki page on reducing noise.

$\endgroup$
  • $\begingroup$ I have a slightly diffuse mirror in my current scene that was causing white dots. Even at 1000 samples it was awful. Filter glossy fixed the problem even at 100 samples. (v2.74) $\endgroup$ – marcusdoesstuff Jul 16 '15 at 15:21
  • $\begingroup$ Actually, disabling Multiple Importance Sample's fixed it for me. I wonder why? $\endgroup$ – Jam Risser Dec 7 '18 at 19:28
1
$\begingroup$

Increase Render Samples

If you are using Blender Internal in an older version of Blender, the Render Sample settings are found in the Render panel in the Integrator section:

enter image description here

If you use Cycles, you can simply increase the Samples in the Samples section of the Render panel:

enter image description here

Experiment with settings of 50, 100, 200 etc. and see which produces the best effect for you.

$\endgroup$
  • $\begingroup$ no matter what number I used it always shows up $\endgroup$ – TXS Apr 19 '14 at 0:25
  • $\begingroup$ Correct me if I'm wrong, but that top screenshot looks like cycles to me.. $\endgroup$ – gandalf3 Apr 19 '14 at 0:30
1
$\begingroup$

If neither of the other answers work, go to whatever your light source is in object mode.

Then, under the properties tab, there will be a little sun-like symbol with arrows. Click on it, and adjust the size under "lamp".

I found that if I increased it, it completely fixed the problem.

You should not need to do any of the other answers here for it to work.

I put my size to 5 when it was down low at 0.0 something.

Hope this helps. I am a newbie and am sorry that my explanation does not have technical terms :).

Also, I am using v. 2.77.3 and rendering with a GPU, though that should not affect it.

Good luck!

Note: This applies to lamps and objects that have an emission shader. If it is an object, you will need to scale it up literally by using scale in object or edit mode.

Because your scene is not enclosed, adjusting the size of the light might not matter to you. However, if this was inside an enclosed room, and your light had to be constrained to a certain size, I am not sure how to fix it. The above methods should be tried.

IMPORTANT: Under the render tab, go to Light Paths, and look at the Filter Glossy tab as the other methods suggest. Adjusting this will definitely help, even though it will decrease the accuracy of the glossy shader...

$\endgroup$
  • 2
    $\begingroup$ This may inded solve or at least greatly reduce the problem with fireflies. However, it has the side effect of making shadows softer. That may, of course, be acceptable or even desirable, but in some cases the sharper shadows caused by smaller light source may be what you're looking for. $\endgroup$ – Duane Dibbley Oct 6 '16 at 2:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.