5
$\begingroup$

My render is appearing black and white in blender. Here is the render: Black and White Minecraft Render

It should appear in these colors: Colored Minecraft Render Note: This is Material Mode, not the actual render.

Here is the file: .blend File

Thanks! :)

$\endgroup$
4
  • 5
    $\begingroup$ Please use the blend-exchange.giantcowfilms.com to upload .blend files internally. Also, you haven't packed anything into your .blend file, so all the textures are missing resulting in everything turning pink $\endgroup$
    – FreemoX
    Commented Aug 2, 2017 at 3:30
  • 4
    $\begingroup$ Please don't crop your screen captures so tight. You are looking at the blue channel only $\endgroup$
    – user1853
    Commented Aug 2, 2017 at 3:34
  • $\begingroup$ @FreemoX i used mcprep so on my screen it's not pink. $\endgroup$
    – LeafyMeap
    Commented Aug 2, 2017 at 3:41
  • 2
    $\begingroup$ @LeafyMeap in the future pack your textures so that we don't get that horrible pink all over. i.sstatic.net/43KPT.png $\endgroup$
    – user1853
    Commented Aug 2, 2017 at 3:47

2 Answers 2

9
$\begingroup$

In the UV/Image editor, you are looking at the blue channel only, individual color channels get displayed in black and white

Switch to RGBA or RGB view.

enter image description here

enter image description here

From the Manual

Draw Channels

The radio buttons set which channels of the image are displayed.

RGBA

Replaces transparent pixels with background checkerboard, denoting the alpha channel.

RGB

Draw the colored image, without alpha channel.

Alpha

Displays the Alpha channel a gray-scale image. White areas are opaque, black areas have an alpha of 0.

Z-Buffer

Display the depth from the camera, from Clip Start to Clip End, as specified in the Camera settings.

Red, Green, Blue

Single Color Channel visualized as a gray-scale image.

$\endgroup$
1
  • $\begingroup$ ok then I'll edit the pic again $\endgroup$
    – LeafyMeap
    Commented Aug 2, 2017 at 3:43
2
$\begingroup$

First thing I noticed, is that you're probably rendering this in greyscale. To render in colors, make sure your RGB option is selected:

enter image description here

This will result in an image lite the one you posted. To fix this, make sure you got the RGB selected like so:

enter image description here

As cegaton mentioned, you are viewing blue hues only, I failed to notice this and edit this answer before cegaton beat me to it. Here's at least a GIF showing what it does (It's all pink because all the textures are missing, but this will work for you) enter image description here

Hope this helps.

$\endgroup$
3
  • $\begingroup$ i'm already in RGB, but it's not working :( $\endgroup$
    – LeafyMeap
    Commented Aug 2, 2017 at 3:42
  • $\begingroup$ You're welcome. In the future, check out cegaton's comment on your question. It shows how to pack all external information (In this case, your textures) into your .blend files. This would make it easier for you to get help in the future for similar problems $\endgroup$
    – FreemoX
    Commented Aug 2, 2017 at 3:49
  • $\begingroup$ ok @FreemoX I will $\endgroup$
    – LeafyMeap
    Commented Aug 2, 2017 at 4:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .