0
$\begingroup$

This question already has an answer here:

How to fix the error shown on screeshots ? Thank you for your answers. enter image description here

enter image description here

$\endgroup$

marked as duplicate by Duarte Farrajota Ramos, Denis, David Aug 2 '17 at 0:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    $\begingroup$ This isn't a bug, but it rather looks like you've messed with the culling settings; docs.blender.org/manual/en/dev/game_engine/…. Try recalculating the faces or flipping them and turn backface culling off $\endgroup$ – FreemoX Aug 1 '17 at 14:51
  • $\begingroup$ To add to my previous comment; Backface culling is the progress of rendering unseen faces. Each face makes a draw call, and normally, only the faces seen by the camera should be rendered. Turning backface culling off, will allow all faces to be rendered. This will slow down the rendering time, but should not affect your game to a noticeable level with your polycount. For small games, you should disable backface culling. I do it myself for small games made in Blender as it makes it more resistant to visual abnormalities. $\endgroup$ – FreemoX Aug 1 '17 at 15:00
  • $\begingroup$ Thank you. Turning backface culling off was a good solution ! :) $\endgroup$ – BBB Aug 1 '17 at 16:15
  • $\begingroup$ Glad it helped you! If this answered your question, please consider marking my answer as the selected answer :) $\endgroup$ – FreemoX Aug 1 '17 at 16:21
  • 2
    $\begingroup$ @BBB Please use descriptive titles and fully describe the problem in the body of your post. Related blender.stackexchange.com/questions/1489/… $\endgroup$ – Duarte Farrajota Ramos Aug 1 '17 at 19:35
5
$\begingroup$

This is most likely the result of flipped faces, resulting in this: enter image description here

One way to fix this is to disable backface culling like so: enter image description here

Or you could simply recalculate/flip normals of the faces: enter image description here

Hope this helps.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.