1
$\begingroup$

I made a simple game when I was bored, blender just saves it as a .blend file when I try to save it as a standalone game. I have the add-on and everything, but it just saves it as a .blend file. I saw one website that said I should copy certain files from the blender directory but I can't find that either. Does anyone know where I can find that directory, or does it work differently for linux, and if so, how do I save it as a standalone game?

I'm running Blender 2.78c with Ubuntu 16.04.

EDIT: I saw this post Linux, Save As Game Engine Runtime not working and one of the answers says that I should check if the player path was filled in, and it is. I got curious and searched for the file, and couldn't find it. Could this be why the blender saves it as a .blend file?

$\endgroup$
  • $\begingroup$ Have you supplied the addon with the path to the blenderplayer binary? $\endgroup$ – gandalf3 Jul 30 '17 at 21:39
  • $\begingroup$ Also are you sure you are using File > Export instead of File > Save? The directory for the files is the place you installed blender to. $\endgroup$ – Duarte Farrajota Ramos Jul 30 '17 at 21:43
1
$\begingroup$

You're probably exporting it wrong. Make sure you have the save as runtime addon enabled (User preferences>Addons>Game Engine). Without this you can't export as a game runtime, meaning people can't play it, like the issue you described.

enter image description here

Once that's done, make sure you are viewing the FIRST SCREEN you want the player to see. Splash screen, main menu, level 1, etc. When exporting, the scene you are currently viewing will be the first thing players see. Also make sure you have selected "Blender Game" under render engine options. Then you're good to export it.

NOTE: I'm on Windows, but should be the same with Linux, part from the .exe obviously.

enter image description here

Hope this helps.

$\endgroup$
  • $\begingroup$ Thanks! It worked. I didn't know I was suppose to enable game engine publishing. $\endgroup$ – Shadeslayer Aug 10 '17 at 1:38
  • $\begingroup$ Glad it helped you! Please consider marking my answer as the solution. $\endgroup$ – FreemoX Aug 10 '17 at 1:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.