6
$\begingroup$

Before anything, I must mention that I've already read all similar questions and answers from this community before posting this one, so no need to close as duplicate, its not duplicate.

My render mode is Cycles. I already properly installed all necessary NVidia drivers etc (all of that were installed by default), so I navigated to File -> User Prefernces -> System -> Cycles Compute Device -> CUDA. But, the problem is because I simply cannot select it. Take a look at the SCREENSHOT 1.

Also, I can select it, but nothing happens. I searched on internet what to do and I didn't find what to do if the option is disabled like in my case. Also, I tried to ignore it and to just enable GPU in render menu. But, it is also disabled there too, see SCREENSHOT 2.

I can select GPU, but nothing happens, it still renders using CPU. What to do in this case? Blender is not complaining about any bugs or errors and I don't see any messages why is it disabled.

Any suggestiong on how to enable it? My processor's CPU is extremelly slow while my GPU is fast, so it would be nice if I success to enable GPU because now almost any scene takes a few months to render (using just CPU). Thank you in in advance.

P.S. if you need some additional information about my OS or blender, no problem I'll provide any needed information. Thank you again.

Edit 1

As answer to ardito's questions. I just clicked all suggested tags which appeared after I finished writing the question, I dont know what a python is btw. Secondly, I cannot paste images using image editor because I need at least I think 50 rep or similar, so i must use links, I also cannot add more than 2 links per question. As answer to your last question, I can select it, (I mean I can click it and change from CPU to GPU), but it is still disabled (you can see that the option is gray, while it should be darker), but the blender still uses CPU to render instead of GPU. I tried everything, I saved it, saved settings, saved file as blend file, restarted computer, restarted blender, restarted operating system, changed computer etc, but nothing works. My version is 2.78c;

Edit 2

How I know it is still using CPU? Well, I cannot know for sure, I just suppose. The main reasong which suggest me that CPU is still being used are following:

  1. The computation time needed for rendering is exact same, not shorter, not longer. I suppose if I change from CPU to GPU at least some scenes should be rendered differently fast (maybe slower or faster), but everything is rendering same speed as when CPU is selected
  2. Both GPu options (in user preferences and in render menu) are disables (they are light gray while they should be color like all other buttons, so dark gray I think) which suggests that something is not normal
  3. Thats it

I know GPU may or may not be slower than CPU on some particular scenes, but the computation time is not changed. I tried with different scenes and it renders exact same speedly. Not faster not slower.

Edit 3

As suggested in comments, I did what he said. So, I launched Blender using command line (I never did it before so sorry if I did it wrong, I had to google it to find how to do that), so then I used blender for a while, tried to do some renderings using gpu and cpu and then I screenshoted the command line window when I closed blender, so you can now see the whole log.

enter image description here

I noticed that blender is complaining about failed to set some frequency whatever that means. Also, I noticed in console message saying that some event has invalid window. What does it mean? Doew it maybe causes the issue? Anyway, you can see the screenshot of console (the log is very short, just few lines) and you all are experts in blender so I am sure you can easily understand what is causing issue by looking at log. Also, sorry for my bad undertsndaing of blender concepts, I am new to programming and new to blender I have no programming or animation experience before (I just bought my first PC), so sorry about it. Thanks ardito for your fast and good responses and comments, I am sure you are good programmer and you can help me solve this probably easy issue for you. Thank you in advance again.

I cannot post screenshot here not more than 2 links are allowed for newbies in this community, so I am posting link in the comments, you can see it in comment section.
Thanks cegaton for importing image.

$\endgroup$
  • 3
    $\begingroup$ Hi, sorry, what "python" and "scripting" tags have to do with this? Also, you should add images using the editor "image tool" so that they are also visible here... Then, it's not clear if you can or cannot select the gpu setting. You say: " the problem is because I simply cannot select it." then "Also, I can select it, but nothing happens"... ? Finally, add the blender version. $\endgroup$ – m.ardito Jul 30 '17 at 15:29
  • $\begingroup$ @m.ardito he cannot use the editor image tool because he has 1 reputation. $\endgroup$ – Tooniis Jul 30 '17 at 15:32
  • $\begingroup$ @Trance-DoarCuTine python is a programming language used for scripting in blender. This question has nothing to do with scripts (so also nothing to do with python)so you should remove both the scripting and the python tags. The suggested tags are not always related to your question. After all it is not a human who suggests these tags so the failure rate is high. $\endgroup$ – Tooniis Jul 30 '17 at 15:44
  • 1
    $\begingroup$ @Trance-DoarCuTine - Wow. Wasn't saying you were color blind, I was wondering if the button was actually working because you said "I simply cannot select it." $\endgroup$ – bertmoog Jul 30 '17 at 20:37
  • 1
    $\begingroup$ I know im a bit late for this, but I remember in older version of blender one had to change the feature set from "Supported" to "Experimental" to get GPU rendering to work. (Render tab, above "Device") $\endgroup$ – tacofisher Jul 31 '17 at 1:04
1
$\begingroup$

Unsure but did you have the latest graphics card drivers installed? The GPU Compute is showing light gray which means the CPU is rendering it instead. Probably due to not installing the right drivers for your Graphics card it isn't getting registered.

  1. Could try updating the graphics card driver from the manufacturers website.
  2. Try enabling experimental mode.
  3. Downloading and installing visual c++ 2013.

If you want faster render you can use SheepIt Free Render Farm It is really useful if you are working on an animation, where if anyone doesn't have the necessary render power to run it might take weeks to complete.

| improve this answer | |
$\endgroup$
0
$\begingroup$

Unsure if this will help:

To know for sure if your render is using CPU or GPU you should notice a change in the number of 'tiles' that are being rendered at a time. A 'tile' is the square with little orange corners that you see being refined in your render image.

EG, if you only have 1 video card, then you will only ever render 1 tile at a time. 2 video cards (you should have SLI disabled) = 2 tiles at once. Most CPU's made in the last 5+ years are multi-threaded - so if your CPU has 4 threads, it will render 4 tiles at a time.

If you go to your render settings tab, under the PERFORMANCE section, select Áuto-Detect' and it will tell you how many threads your CPU has.

This isn't a fix, just a way of identifying if you are actually rendering on the GPU or CPU.

Otherwise, could you state the model of CPU you have and the exact brand/model of your video card? I can do some research... some older AGP cards do not support CUDA, but I can't remember if the 750 was ever made using AGP.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.