1
$\begingroup$

I'm doing an interior scene seen from the outside through a big wall of glass. It's just after sunset, so there is still some light from the HDRI image. I want the light to flow to the outside.

I don't know how many solutions that I have tested with emitting materials. If I use a plane that are located close to the celing I get too much light upwards and to solve that I use another plane between the emitting material and the celing to stop the light. Both planes are invisible for the camera and casting no shadow, but still I get a dark och almost black celing. I guess it's because I stop the light from reaching the cealing. If I lower the emitting plane, I get shadows from the side of the plane. Nothing looks nice! :(

I have made some spotlights in the celing and given them some emitting light, but not to much, because if there are too much light, they look unreal. I have six spotlights and if I increase the value to light to interior, I get a lot of strange noise on the walls.

I have also used spheres and I have to use a plane above the sphere also to stop the light.

Any other solutions or tricks to light up an interior scene? Help is preciated? Most tutorials about interior lightning is about daylight.

$\endgroup$
1
  • 1
    $\begingroup$ It would be easier to see the problem if you add a picture of your scene $\endgroup$
    – tacofisher
    Jul 29, 2017 at 15:59

1 Answer 1

2
$\begingroup$

If I got your question right you can achieve it using a Backfacing output of a Geometry node. enter image description here

Set the nodes as pictured below. Use Backfacing as a factor for mixing between Emission and Transparent nodes.
enter image description here

To make each side emit different light values and colors set the nodes in similar way. enter image description here enter image description here enter image description here

$\endgroup$
2
  • $\begingroup$ Thanks for the help! With this nodes the result was much better, but I don't see any difference when I change the value in the mix node and I still get a thin shadow from the side of the plane if it's close to the wall. Any options to hide this shadow? $\endgroup$
    – 3D-kreativ
    Jul 30, 2017 at 8:36
  • $\begingroup$ Nice to hear I helped :). To hide the shadow please see this answer: blender.stackexchange.com/questions/68278/… $\endgroup$
    – Paul Gonet
    Jul 30, 2017 at 17:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .