0
$\begingroup$

To build my tank for a Unity game, I am using Blender. Currently, I am making a turret consisting of an isosphere with half of the faces removed (I needed the bottom to be "flat") with some minor visual edits, two cylinders (one is the hatch, the other the antenna), and a cube to act as a hinge:

enter image description here

The inside is hollow. When I imported it to Unity (drag and drop from File Explorer straight to Unity Assets folder), the entire isosphere was missing as you can see from the preview:

enter image description here

I have tried to correct the normals with CTRL-N as mentioned in other Blender forum pages but it still doesn't work. How exactly do I make my isosphere appear in Unity? Also, after some testing, the shapes don't affect the isosphere (it won't load even by itself), the scale is positive, and the normals are all facing outside.

$\endgroup$
  • $\begingroup$ @MrZak Actually, they are are all positive (+1) $\endgroup$ – Anthony Pham Jul 28 '17 at 21:28
  • $\begingroup$ Is it possible for you to share the file? I didn't really use drag-and-drop to Unity import feature, did you try exporting fbx and importing it there? If the object isn't imported at all then it's likely not a Blender problem but import/export mismatch $\endgroup$ – Mr Zak Jul 28 '17 at 21:45
  • $\begingroup$ @MrZak Oh thanks! Exporting to .fbx first worked $\endgroup$ – Anthony Pham Jul 28 '17 at 21:48
  • $\begingroup$ As I see the object won't really be rendered in Blender at all because it's Duplication in Object tab in Properties editor is set to empty Group. Try setting that to None and exporting again. Working with fbx probably means that was something with .blend import into Unity $\endgroup$ – Mr Zak Jul 28 '17 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.