1
$\begingroup$

I set up a scene with a glass sitting on a plane with wood texture and I wanted to see how it looks. I rendered it and the glass and it's shadow was pretty noisy. I tried increasing the samples from 128 to 1280 but it became even more noisy and the shadow became weird. I tweaked around the settings and I found out that if I disable Multiple Importance for the light source, the noise goes away. But why is this? I heard that MIS is supposed to REDUCE noise, not increase.. Images: Since I can't post more than 2 images I zipped them (also, I included the .blend too). [LINK]

filenames: glass [samples] MIS [ON/OFF]

I used cycles renderer.

$\endgroup$
1
$\begingroup$

Some links to point you in the right direction:

Ways to get rid of fireflies (White pixels in your render)

Reduce noise in Cycles renders

The noise can be caused by a lot of factors and is a common issue with Cycles. I've personally found that Filter Glossy and increased clamping combined with more samples work best for me, but it's totally depending on your type of render. But I render a lot of glass myself, so I would assume this would work for you as well. But then again, check out the links I gave you for some good tips.

$\endgroup$
  • $\begingroup$ Tried all of these but nothing worked when MIS was on. Interestingly setting the light size LOWer (the first one said make it higher) decreased the noise. $\endgroup$ – VDavid003 Jul 28 '17 at 16:11
  • $\begingroup$ Never experienced that before, larger lights usually mean less noise. It almost sounds like you've messed around with the wrong settings for your glass object? $\endgroup$ – FreemoX Jul 28 '17 at 16:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.