1
$\begingroup$

enter image description here

The bottle is simple glass shader and the desert is a deformed plane mesh with thickness. But as we can see, the bottle buried gives a really weird look of deep black hole. I want to get rid of this black hole with filling it with sand. How can I achieve this?

$\endgroup$
4
  • $\begingroup$ It would help to upload your file, or your sampling settings. Make sure you force enough transparent samples. $\endgroup$
    – Leander
    Jul 28 '17 at 13:45
  • $\begingroup$ You want the bottle to have sand in it or you want the black part on the outside of the bottle to be sand? $\endgroup$
    – bertmoog
    Jul 28 '17 at 14:17
  • $\begingroup$ @Leander It worked. I extruded the plane instead of solidifying. $\endgroup$
    – 4-K
    Aug 4 '17 at 18:56
  • $\begingroup$ @bertmoog It worked. I extruded the plane instead of solidifying. I wanted the black hole to disappear so I could see the sand. $\endgroup$
    – 4-K
    Aug 4 '17 at 18:57
3
$\begingroup$

The first step is to make a cavity in the sand. I can't tell from your image if you've done that or not. I used the Boolean Modifier (to save time) in order to make this hole the same size as the bottle, but you can also model it which would be more beneficial in the long run:

enter image description here

Adding more bounces to any of the Light Path inputs will result in longer render times and has diminishing returns. I would set the Transmission bounces to around "5" since there's little difference beyond that:

enter image description here




What you really need is a node setup that will allow you to adjust how much shadow is cast on the ground and in the hole. This node tree has been around the block a few times and it's still just as effective. Adjust the Multiply factor to remove shadow caused by the Glass Shader. Zero is full shadow, one is no shadow:

enter image description here

Here is the final with a factor of 0.8:

enter image description here

$\endgroup$
2
  • $\begingroup$ It worked. I extruded the plane instead of solidifying. $\endgroup$
    – 4-K
    Aug 4 '17 at 18:57
  • 1
    $\begingroup$ @4-K - glad you were able to get it working $\endgroup$
    – bertmoog
    Aug 4 '17 at 20:19
1
$\begingroup$

It's likely that you simply need to increase the amount of transmission-bounces under the "light paths" section in the render settings.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.