0
$\begingroup$

I did setup an easy scene with an area light behind a window. In the glass (simple plane) which is in front the area light is visible - how can I turn this off so that the background is shining throgh?

Scene Render Result Glas Node Setup

$\endgroup$
3
  • $\begingroup$ related: blender.stackexchange.com/q/17910/19287 $\endgroup$
    – Dan
    Jul 28 '17 at 11:42
  • $\begingroup$ if you go to the object tab (orange cube) and then cycles settings and uncheck "Camera" does it solve your problem? $\endgroup$
    – user27460
    Jul 28 '17 at 11:44
  • 1
    $\begingroup$ Hi Matt - wrong setting, but the right direction. If I turn off 'Transmission' in the cycles setting it does work ! Thanks for pushing me into the right direction ! $\endgroup$
    – Thorsten
    Jul 28 '17 at 12:34
2
$\begingroup$

Thanks to Matt this is now solved. In the Cycles Settings of the Area Light I turned off the setting for 'transmission' and therender shows what I want :)

Problem solved

$\endgroup$
2
  • $\begingroup$ Anyone know how to get this working in Blender 2.91? I want the light of an area light to affect the scene but don't want the are light's shape to appear on reflecting objects. Turning Transmission off for the light und Visibility doesn't do it. $\endgroup$ Jan 6 at 12:41
  • $\begingroup$ Nevermind, found that it's the Glossy flag that switches this on/off. $\endgroup$ Jan 6 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.