0
$\begingroup$

I have rigged an ant by parenting each bone of armature and then parenting every ant part to its corresponding bone. For animation purposes i have created empty objects in the ant's feet position and then i target every leg to these empty objects so i can move the ant's body with IK while its feet stand still. And it works good. I move the ant's head and it behaves as expected, but when i Lclick or press enter the ant's head moves to ant's abdomen. I have reparent everything to be sure there are no hierarchy loops in bones or objects. I have applied IK to every bone but unapplying individual IK and applying Auto IK is not working either because unconnected (but parented) bones dont follow children bones. ¿Any help?

I include this vídeo: https://youtu.be/xVvyRvFnNec

it moves weridly when click left button or enter It works good while moving a child bone. But when I click LMB or press enter, the bone moves to the abdomen

$\endgroup$
  • $\begingroup$ are all transforms applied? (rotation, scale etc) $\endgroup$ – VRM Jul 27 '17 at 3:44
  • $\begingroup$ Well, there is a little difference between pose position and rest position due to targets in legs, but all bones transforms are reset. In rest position the ant transforms are the same in object, edit and pose mode. $\endgroup$ – Baalhug Jul 27 '17 at 12:17
  • $\begingroup$ It's like the moved bone is trying to move to pivot point of the armature (main parent bone) $\endgroup$ – Baalhug Jul 27 '17 at 22:11
  • $\begingroup$ I discovered something important: if I do any action after moving the ant and pose goes weird, and then i undo (ctrl+Z) that second action, then armature goes to right pose, where it should be when clicked. I'm gonna try to animate it this way: move, action, undo action. EDIT: It works. I move pose, on apply it goes weird, i TAB to object mode, TAB again to pose mode and now armature is where it should be. $\endgroup$ – Baalhug Jul 28 '17 at 12:15
  • $\begingroup$ The problem wit this method is now main bone cant be moved like this. If i pull children bones that move main bone, when it's applied and goes weird and then i double TAB or CTR+Z main bone returns to initial position. :( $\endgroup$ – Baalhug Jul 28 '17 at 23:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.