2
$\begingroup$

enter image description hereIf I go to the Node editor and press Shift+A every action is grey and I can´t click anything. I started to model a waffle(I'm at the very beginning of modelling) and wanted to make a material for it in the node editor but every action in Shift+A is grey and unclickable. Even returning to factory settings doesn´t help. Here is the project:

https://www.dropbox.com/s/fdqqbnyq57cgwng/Waffel.blend?dl=0

I hope somebody can help me.

$\endgroup$
  • 1
    $\begingroup$ did you enable "Use Nodes"? $\endgroup$ – VRM Jul 26 '17 at 16:51
  • 2
    $\begingroup$ Hi. Please use blend-exchange.giantcowfilms.com for more permanent blend file hosting. Also, uploading a blend file should be secondary to a clear description of the problem (which you have done) and preferably some images to illustrate your point. Ideally, we want to try and answer the question without having to rely on a file to be downloaded. $\endgroup$ – Ray Mairlot Jul 26 '17 at 17:01
  • 3
    $\begingroup$ @Abraskus Then please post an answer below in the answer box. $\endgroup$ – Ray Mairlot Jul 26 '17 at 18:00
  • 1
    $\begingroup$ You found one more way to make node adding menu greyed out which wasn't outlined in this answer, which is trying to add nodes to object when it doesn't have any material. Object must have a material for nodes $\endgroup$ – Mr Zak Jul 26 '17 at 19:18
  • 1
    $\begingroup$ When you say the solution was "changing a few things" what do you mean? Others with a similar problem could use your experience. $\endgroup$ – user1853 Jul 26 '17 at 22:48
4
$\begingroup$

You need to add a new material. Press "New" in the bar below the node-editor window.

enter image description here

make sure the "use nodes" is ticked.

enter image description here

$\endgroup$
  • $\begingroup$ Would be good if you showed the screenshot before you pressed 'New'. It might be hard for a user to understand where they would see the 'New' button going by your screenshot. $\endgroup$ – Ray Mairlot Jul 27 '17 at 14:54
  • $\begingroup$ the new shows on the screenshot of Abraskus. At least that was my train of thought. i wanted to show the use node checkbox. - added it anyways. $\endgroup$ – Madlaina Kalunder Jul 27 '17 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.