4
$\begingroup$

How can i make the grass bend when this cube hits it?

Here's the picture:

enter image description here

$\endgroup$
  • 2
    $\begingroup$ there is a link at the bottom left of your question to edit the original post. Use that to add information and corrections. Also please use blend-exchange.giantcowfilms.com to upload files. To add images use the tools available on this site: Please read: blender.meta.stackexchange.com/questions/1080/… $\endgroup$ – cegaton Jul 26 '17 at 4:43
  • $\begingroup$ @Tucker Should grass stand up after the hit or should it lay on the ground after it? $\endgroup$ – cgslav Jul 26 '17 at 6:05
4
$\begingroup$

Final:

Final

Overview:

Whole process is very easy. You will only need to make your grass object as Cloth or Soft Body (with Weight Paint) then Convert Particle System to mesh and delete Particle Emitter as it will not longer be needed. Then add to your Cube Collision.

First of all you will need to choose if you want to use Cloth or Soft Body. Quick test shows me that Cloth simulation is fairly faster, but Soft Body will give you probably more options, as Plastics, Edge Stiffness and such.

Secondly I don't know why (and maybe someone can correct me) when your object is in Particle System simulation works, but Pinning/Soft Body Goal won't. Maybe it's a bug or maybe there is an explanation.

Note: Below steps could vary from your scene setup so don't take them as granted. I will point out most important settings and you could tweak them for your needs.

Steps:

Grass strand.

Grass

  1. You will need to Weight Paint your grass strand. Red is stiff, green is... less stiff. You can experiment with this as you like to make grass really soft or hard.

  2. Add to your object Cloth Simulation. I have used settings as you can see on the image. Most important things here are:

    • Mass - it should be really low, higher will make grass to lay on the ground,
    • Pinning - from Weight Paint, it will keep grass strong at the bottom and weak at the top, or not if you painted it differently,
    • Velocity - how fast grass will return to base position,
    • Cloth Collision - check also Self Collision, there are lots of them so it will make simulation more realistic.

Particle Emitter.

Nothing special here, only after setting your grass go to Modifier Tab and Convert Particles then delete Particle Emitter.

Blend file:

$\endgroup$
  • $\begingroup$ This works fine for me in 2.79 but your blend file doesn't work in 2.8 any idea? $\endgroup$ – Wes Apr 27 at 16:08
  • 1
    $\begingroup$ @Wes yes, this is because Blender 2.80 introduced new Cloth simulations. You can read about it here: code.blender.org/2017/06/improvements-to-the-cloth-simulator I can try to make it work with new settings but you should be able to tweak it properly. $\endgroup$ – cgslav Apr 28 at 14:23
  • $\begingroup$ I got it working for this particular use case (your file) by turning off self collision. However it doesn't help me for the use case I was hoping to solve when downloading your file. I'm finding the cloth/hair simulation a bit broken at the scales I'm trying. A hair emitter just with hair particles falling onto a collision surface causes some crazy effects. Thank you I'm not disputing your comment. Also thanks for the link. $\endgroup$ – Wes Apr 29 at 7:36
  • 1
    $\begingroup$ @wes I didn't had time and reason to test the new simulator, but first quick attempts wasn't very appealing to me also. You can drop your file somewhere and post a link, I'll try to think of something if you want. $\endgroup$ – cgslav Apr 29 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.