There is a camera following a path, and when I press I while over the Follow Path > Offset field, it throws an error of F-Curve with path 'contrains["Follow Path"].offset_factor[0]' cannot be keyframed, ensure that it is not locked or sampled, and try to remove F-Modifiers. There are no F-modifiers and it isn't locked or sampled. It has a Limit Rotation constraint on it as well but removing that doesn't help. How can I resolve this?

  • 2
    $\begingroup$ If you use the animate path option there are no keyframes, the animation is controlled then by the evlauation time on the curve. See this related link: blender.stackexchange.com/questions/21041/… $\endgroup$
    – user1853
    Commented Jul 26, 2017 at 0:32
  • $\begingroup$ Yeah you are not supposed to be animating that value, that is for a permanent offset. You animate the Evaluation Time in the cuve object itself $\endgroup$ Commented Jul 26, 2017 at 0:35
  • $\begingroup$ also related: blender.stackexchange.com/questions/23835/… $\endgroup$
    – user1853
    Commented Jul 26, 2017 at 0:36
  • $\begingroup$ Or you can get rid of the modifier on the curve editor and then animate the offset value normally. $\endgroup$
    – user1853
    Commented Jul 26, 2017 at 0:37
  • $\begingroup$ Heh, that is interesting, because i've been following advice to do exactly that, and it has worked the last few times. It's from this tutorial - youtu.be/9-44yRfQ-A0?t=4m52s . I'll try to do it the proper way, then. Although for something simple like this, it did work well, until now. $\endgroup$
    – kim holder
    Commented Jul 26, 2017 at 1:03

2 Answers 2


I downloaded your .blend file and found that if you uncheck the "Fixed Position" box, you can keyframe the "offset" value and it works fine.

Hope this helps!

  • $\begingroup$ It did help, but there were other issues. The camera moves when the offset is in negative numbers (even though it was aligned with the direction of the path). I tried putting the ending keyframe on it when it was at the end of the path, with a value of -100, but the animation still wouldn't work. $\endgroup$
    – kim holder
    Commented Jul 26, 2017 at 17:43

Though it isn't what the offset field is meant for, and so unless you are doing a very simple camera animation doing this will get you in trouble, keyframing it does work. The technique is shown in this tutorial.

I think doing the steps out of order is what got me in trouble, although I haven't reproduced the problem. The file attached to the question has the offset values 'backwards' - the camera moves along the path when the numbers there are negative, so trying to control its motion by putting keyframes at position 0 and 1 (with the Fixed Position box checked) couldn't work and perhaps was the source of the error.

Deleting the camera and starting over resolved the problem. I did all the other setup of the camera before putting in the keyframes and it now works

  1. Add a Follow Path Constraint to the camera and make the Target the path curve you have made for it to follow
  2. Clear its Position and Rotation with Alt G and Alt R (so it isn't offset from the path)
  3. Check the Follow Curve box and the Fixed Position box, click '-Z' for Forward, and 'Y' for Up
  4. Don't click Animate Path!
  5. Don't futz around moving the camera and adding to the path before doing the next step. Do it immediately, and then futz around.
  6. If you accidentally do either of the previous 2 things, it will likely not work now and you will need to start over. In this case, not even redoing the constraints helped, I had to delete the camera and start over with a new one.
  7. Put a keyframe on the Offset field when it is at 0 (by pressing I while the cursor is over the field), and then change Offset to 1 and put in another keyframe.

blender screenshot showing steps above

Another description of a similar process is in this answer by cegaton, which was mentioned in the comments on the question.

Now, I do in fact want to put normal offsets on the camera, which is what the Offset Field is actually meant for - I'd like the camera to move faster on the beginning of the path. So I may go to the effort of setting up the camera animation the standard way, in the Graph Editor.

  • 1
    $\begingroup$ A couple of notes: on step 2, Clearing Location and Rotation works well with the camera (since it has no "origin") but for other objects it is important to remember that you need to have the curve and the object have their origins in the same place for the object to travel along a path. The values for the offset are related to the evaluation frames for the curve, so an alternative way to animate the motion is to animate the evaluation time instead of the offset. $\endgroup$
    – user1853
    Commented Jul 26, 2017 at 16:53
  • $\begingroup$ @cegaton it doesn't seem to be necessarily true that the offset is related to the evaluation frames - if you don't click 'Animate Path', there is no evaluation time, it works purely through the offset value. $\endgroup$
    – kim holder
    Commented Jul 26, 2017 at 16:58
  • $\begingroup$ Maybe that's just semantics... $\endgroup$
    – kim holder
    Commented Jul 26, 2017 at 16:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .