I tried installing animation nodes. Blender thought it installed it but it actually didn't (because it was the windows version and I was using Linux). I realized this when I ran into this problem. So I deleted that zip and downloaded the linux one. Now it shows up in the Add-ons folder when I select the .zip (as shown below) enter image description here

but when I click the checkbox to enable it, it gives me this error message: enter image description here

Thinking that Animation Nodes is already installed, even though the Windows version didn't show up in the Add-ons panel or anywhere on my hard drive. How can I get the proper version installed?

  • $\begingroup$ Go to the folder for the addons and delete the wrong version. The addons can be in two places C:\\program files\\Blender Foundation\ Blender\Version\scrips\addons\ and in C:\\Users\YourUserName\AppData\Roaming\Blender Foundation\Blender\version\scripts\addons. Delete form both places and Then start blender, and install the addon again from the User Preferences using "install from file" $\endgroup$ – user1853 Jul 25 '17 at 22:27
  • $\begingroup$ I'm using Linux so I don't have those locations on my hard drive. And when I do a search, I cannot find the old files. $\endgroup$ – Anson Savage Jul 25 '17 at 22:33
  • $\begingroup$ Then look for the places where the addons are. Depending on how they are installed on your system. should be something like /home/your user/.blender or something like that. it might be a hidden folder one starting with a period before the name. $\endgroup$ – user1853 Jul 25 '17 at 22:35
  • $\begingroup$ I already deleted all instances of the wrong version, as far as I can tell. Can I locate the user settings file and tell it that I don't have it installed anymore? $\endgroup$ – Anson Savage Jul 25 '17 at 23:02
  • 1
    $\begingroup$ Type bpy.utils.script_paths("addons") into the python console. This will return a list of known addon locations. In my case ['/home/batfinger/src/BlenderGIT/kdev_build/bin/2.78/scripts/addons', '/home/batfinger/.config/blender/2.78/scripts/addons'] Remove addon from one of these locations. If the addon is in the blender contrib, as is animation nodes, I'd suggest removing the .config one. $\endgroup$ – batFINGER Jul 26 '17 at 9:48

Click the disclosure triangle for the addon, you can find the path to the addon file in the info there.

addon path

  • $\begingroup$ Thanks! batFINGER's comment solved it. I appreciate the help. $\endgroup$ – Anson Savage Jul 26 '17 at 21:44

Both @cegaton's and batFINGER answered this correctly. I needed to go into the .config folder found in:


This helped blender to forget that it was installed.



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.