2
$\begingroup$

My cloth simulation sometimes works fine, but other times it does this.

Modifiers  Cape is jagged

This usually happens when the character jerks on to the cape suddenly.

The top of the cape dose have a vertex group with 100% power, pinning it to the character, and the rest of the cape has only 10% power so it stays near him.Vertex group

If you know how to stop the cloth simulation from going jagged at points then please let me know.

$\endgroup$
  • $\begingroup$ Can you post a screenshot with your modifiers? $\endgroup$ – Paul Gonet Jul 25 '17 at 15:29
  • $\begingroup$ @Paul Gonet Ok. All I have is a cloth simulation. $\endgroup$ – JustNat Bro Jul 26 '17 at 11:15
  • $\begingroup$ How big is the blend and could you just export the character/cape to it's own blend file and post it: blend-exchange.giantcowfilms.com $\endgroup$ – bertmoog Aug 1 '17 at 15:20
  • $\begingroup$ @bertmoog I could but i'm not looking for a specific fix for just that .blend. I've got a few .blend's with cape simulations. I'm just looking for the best way to make a cloth sim into a cape. $\endgroup$ – JustNat Bro Aug 1 '17 at 18:14
  • 2
    $\begingroup$ The reason you aren't getting much activity is because we have nothing to look at except a brief explanation and a few images. I recommend you uploading a stripped .blend file so we can take a look at it if you're as in such a hurry as you make it sound like. $\endgroup$ – FreemoX Aug 1 '17 at 19:02
0
$\begingroup$

Well it seams the character movement is sometimes too fast. You described this yourself, but you got to think about that. I mean the cape works on physics, if your character makes increadable movements, or turns, then the simulation tries to solve that.

What's often done though is that 'helper' objects are used with a simpler mesh layout. (so for example when superman would raise his arms to prepare for flight...) then his body mesh will not interact at all with the cape, usually a helper mesh is invisile and made with far less mesh faces as to simplify (speedup) the emulation.

$\endgroup$
3
+50
$\begingroup$

Try increasing the number of Steps under the cloth's Quality setting. Don't be afraid to increase it 3 or 4-fold: the simulation time will just increase proportionally (it will take 3 or 4 times longer to simulate), not exponentially (like with sub-surface steps).

When you increase the Steps count to - say - 15, each frame is split by the simulation engine in 15 sub-frames for calculation purposes. This is very useful when the collision/pinning objects have sudden accelerations, because it allows for the engine to deal with them in a finer way, in this case one fifteenth at a time.

Here's a comparison between a Quality = 2 steps and a Quality = 30 steps simulation. As you can see, the sudden accelerations create persistent and unrealistic wrinkles in the low-quality cape, while the high-quality one effectively and rapidly smooths them out (please note: my cape only has the 100% pinning on the top edge, and not the additional 10% one).

example

Additionally, you may want to increase the Quality value in the Cloth collision panel, but this isn't as relevant as the cloth quality.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.