1
$\begingroup$

I don´t know if this is a bug only to me or a common problem, for I don´t know why it occurs.

I had a problem once before where some edges of my model got jagged with black holes when switching to rendered mode (or actual rendering). Answers I got said that I modeled in too much detail or too small, and used the combination Subdiv Modifier/Auto Smooth/sharp edges wrong.

Now I have a way more problematic thing. I have a really simple scene, but most of the edges have this annoying jagged problem. I build this model in a higher scale (since the last one was too small).

I used the Subdiv Modifier/Auto Smooth/sharp edges again, but if I toggle on/off the Subdiv Modifier/Auto Smooth/sharp edges/seams, shade smooth/flat, won´t help at all. These artifacts just keep showing.

Does anyone know why this occurs?

Shaded Flat and zoomed in for a better look on the artifact.

_jaggededge_closeupFLAT

My hardware specs are

  • GPU: Asus M5A78L-M LX3
  • GPU: NVidia GTX 750 StormX OC
  • CPU: AMD FX6300 @ 3,5 GHz
  • 8 GB RAM
  • Windows 7 Professional 64-bit
$\endgroup$
  • $\begingroup$ I don't see any edges like on your screenshot on that model, but try decreasing End clipping values in the View rollout in the Properties shelf. Also include information about what graphic card do you have, it is possible this is a bug $\endgroup$ – Mr Zak Jul 25 '17 at 9:06
3
$\begingroup$

Reduce your Clipping Distance for both the viewport and/or camera.

You have it set to $0.1$ - $10`000$ while you work at around a scale of $1$.

If you reduce the Clipping Distance to something reasonable like $100$, the artifacts disappear.

Clipping distances are used to calculate the Z depth buffer, which is the scene depth information, since it is limited to the available grey scale values of an image stretch across the whole depth of what is displayed, if the values are too far apart there is not enough precision left to represent minute details.

Always keep these values as close as possible to comfortably work, and with a magnitude matching your scene unit scales.

enter image description here enter image description here enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ How is it set to 10 000 for you? As I downloaded it was 1 000 (which is also too much but will not cause artifacts) $\endgroup$ – Mr Zak Jul 25 '17 at 9:10
  • $\begingroup$ Typo, and still causes artifacts at 1000. i played around with the settings. I updated my post to show the difference between 10.000, 1.000 and 100 clipping. $\endgroup$ – AdamTM Jul 25 '17 at 9:17
  • $\begingroup$ Thanks a lot! That solved it! But why is it causing that though? I mean, I saw people building up scenes with a scale that would need waaay more than 100 for the clipping distance, and they don´t have any problems. $\endgroup$ – NGCHunter2 Jul 25 '17 at 21:52
  • $\begingroup$ If they use higher values for clipping, they dont work on your scales though. The artifacts only appear when you zoom in to almost the smallest scale available in Blender. $\endgroup$ – AdamTM Jul 26 '17 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.