3
$\begingroup$

This question already has an answer here:

I just created a 3D model of a barrel and UV unwarped. That thing below is the screenshot of the UV image editor. uv image editor.

Then I clicked new button below the UV image editors window and gave a name barrel and unchecked the alpha option, and selected blank to color fill option then clicked ok. then I changed the viewport to texture mode. I can't see the color grid texture on my object. Image below. full image

i am using blender 2.78n thanks in advance for any help.

$\endgroup$

marked as duplicate by cegaton, Duarte Farrajota Ramos, Scott Milner, metaphor_set, David Feb 26 at 3:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

5
$\begingroup$

UV unwrapping just deals with the coordinates for the mapping of a texture it does not assign the image to the material automagically.

In order to have an image be part of the material, you need to edit the material add an image texture node and connect the color output to the color input socket of the shader, then the UV coordinates as vector for the mapping.

enter image description here

$\endgroup$
  • $\begingroup$ thanks for the help. I am new to blender can you please suggest me any good texturing and UV mapping website or video. where I can learn from. $\endgroup$ – Atanu Mondal Jul 24 '17 at 17:18
  • $\begingroup$ @AtanuMondal Yes, Youtube is chock full of tutorials, just search $\endgroup$ – Duarte Farrajota Ramos Jul 24 '17 at 18:20
  • 1
    $\begingroup$ @cegaton Thanks for taking the time to properly answer this question, this pops up so often and there was no good answer to point duplicates to. About time we get a proper reference for marking duplicates. $\endgroup$ – Duarte Farrajota Ramos Jul 24 '17 at 18:22
  • 1
    $\begingroup$ I recall that for 2.7x you don't need to hook the Image Texture node up to a shader, output, or any other node for it to appear on the target object when in the Texture shading mode. It seems, though, that no such shortcut is possible in 2.80 (there's no longer a Texture mode) so a node setup like the one shown in this answer is required. $\endgroup$ – B Layer Feb 13 at 19:43
1
$\begingroup$

The problem could also lie in your settings for the mesh if you've set max. draw type to something else than texture. See first post with image here:

https://forum.kerbalspaceprogram.com/index.php?/topic/157177-solved-why-is-my-texture-not-showing-in-blender/

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.