1
$\begingroup$

I'm sorry for my last question I wasn't know what I have to upload to make my question clear also I'm a beginner ...

I have finish my tracking then try to render using F12 the result as shown in the screenshot
it show only a shadow

it show only a shadow

and as you asked I will upload .blend file

https://www.mediafire.com/?x5d1n0z99iufle3

please help me with this problem ..Thank You

$\endgroup$
4
  • $\begingroup$ Hi, next time please use blend-exchange.giantcowfilms.com to upload your file (it's dedicated and permanent) then edit your question and append the provided link. That said, I got your file, and it seems that is your node setup to screw it up, apparently. Probably the (complicated) alpha setup makes your suzanne mesh transparent and so it isn't visible... $\endgroup$ – m.ardito Jul 24 '17 at 7:54
  • $\begingroup$ also, I connected a viewer node to the renderlayer node using "foreground" and it shows nothing... ?! maybe I'm missing something... $\endgroup$ – m.ardito Jul 24 '17 at 7:59
  • $\begingroup$ I guess your're trying to set up a "shadow catcher" in your scene, see this recent question: blender.stackexchange.com/questions/85100/…. I suggest you to try 2.79 rc1 and use the new "shadow catcher" feature... $\endgroup$ – m.ardito Jul 24 '17 at 8:06
  • $\begingroup$ Open my file and try to change it so the object appear in the rendering mod and tell me how you do it $\endgroup$ – Sulimaan Alaabri Jul 24 '17 at 8:10
0
$\begingroup$

I believe it is because you are using the multiply node in the compositor. The multiply node is kind of like mixing two things in a way so that the brightness value is the factor (sorry if this doesn't make sense, there are lots of better explanations out on the internet). When you multiply the Suzanne and the movie clip, since the suzanne is white, it doesn't show through.

I made a few changes to your composite setup. First I checked the Object Index pass under the Render Layers tab. I assigned Suzanne a pass index of 1 and the ground a pass index of 2. I wasn't able to get a good picture so I'm attaching a link to the .blend file but essentially, I masked out everything but the Suzanne and then used the mask to mix the head back in if that makes sense. Here's what the render looked like. Of course you would replace the color grid with your video.

enter image description here

Hope this helps! Good luck!

$\endgroup$
5
  • $\begingroup$ Thank you for your help ...you do change the background ..it helps me 50% because of the background.. thank you for your helping I appreciate it $\endgroup$ – Sulimaan Alaabri Jul 24 '17 at 8:33
  • $\begingroup$ well for the background, you just need to replace the image input node with the color grid with a movie clip node and your video $\endgroup$ – user27460 Jul 24 '17 at 8:39
  • $\begingroup$ Your answer is 100% correct and solve the problem $\endgroup$ – Sulimaan Alaabri Jul 24 '17 at 9:12
  • $\begingroup$ I have a problem with the node if you have a video how I can do it I'll be more than happy Thank you $\endgroup$ – Sulimaan Alaabri Jul 24 '17 at 9:13
  • $\begingroup$ not entirely sure of what you need help with now but essentially, you need to delete the "Image" input node. Press Shift A and add a Movie Clip node, select your video, then connect the Movie Clip to the nodes that the Image was previously connected too $\endgroup$ – user27460 Jul 24 '17 at 17:34
0
$\begingroup$

I tried a simple setup for you, based on the above comments: of course I have not your movie so I couldn't use your tracking setup (instead I used a fixed image just to give the idea). And, I used the new 2.79 rc1 shadow catcher setting (of course this using the Cycles renderer)

enter image description here

As you see the node setup is way more simpler than using previous blender versions...

Maybe this helps you, maybe not, but anyway I think it will at least in future projects.

$\endgroup$
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.