I'm trying to animate a neon sign that blinks, but I'm having trouble with my materials. Here's the .blend file

I am using the Blender Internal renderer. In order to have a neon sign that blinks I created a material that uses nodes to alternate between two simple materials.

material nodes

The "Fac" property on the mixes is animated using constant interpolation so it toggles between 0 and 1.

One of the materials (neon phase 2) works just fine. Unfortunately, neon phase 1 (which is the "opposite") does not. When it is off it is not translucent like glass. It is a shiny opaque grey.

What is the critical difference between the two node-based materials that makes one work correctly, and the other be opaque all the time? How do I fix it or work around it?


Thanks to Vailreth from IRC. He noticed that the Transparency under Render Pipeline Options (which started out minimized) was not checked on the problem material:

enter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.