I'm having an odd issue - When I try to zoom in on a detail using my MMB, the "camera" in the 3D view seems to be cutting off the exterior surface of my object and showing me the inside instead. I'd expect this behavior, but only when I was much more zoomed in. If I zoom out a bit (one click on the scroll wheel) then I can see the exterior as I intend.

Is there any way to adjust this behavior? Thanks!

enter image description here

Clipping in the 3D Viewport:

It sounds like you have your camera's Start Clipping Distance set too high in the 3D Viewport Properties. Clipping distances define the range (in distance units) within which objects are visible. If your distances are set incorrectly, your view gets "clipped" when you cross the clipping threshold, as you describe. To change the 3D Viewport clipping settings:

Properties panel (N) -> View section -> set the Clip Start distance lower

(NOTE: These settings only effect display when NOT in Camera view)

enter image description here

You can read more about clipping in the 3D Viewport here.

Camera Clipping Settings

Just so you know, there is also the option to adjust the clipping range of a camera. This effects the scene when viewed through the camera, such as in Camera View or when rendering. To change these properties:

Select camera -> Object Properties window -> Camera tab -> Lens section -> adjust the Clipping Start and End values

enter image description here

To visualize the camera clip distance, select the camera and enable Display > Limits.

enter image description here

You can read more about camera clipping distance here.

  • Thom,thanks for the response. The problem is not with the actual camera perspective. It's with the user perspective. Is there a way to adjust the clipping distance for that? Nevermind...I found it. – Vadaar Apr 13 '14 at 16:17
  • Just out of curiousity, what might be the use of this feature? – Peter Gašperan Jan 7 '17 at 22:17
  • @PeterGašperan I am not familiar with it, but this is what I found on google: Purpose of camera clipping – Thom Blair III Jan 8 '17 at 1:33

The issue you're having has to do with the "clip point".

Blender sets limits past which objects will not get displayed.

There is a start (close) and end (far) clip point. To change press N and look for the clip settings in the View rollout. Change the start clip to a lower number.

ClippingViewAdjust

protected by cegaton Mar 19 at 2:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.