1
$\begingroup$

https://www.youtube.com/watch?v=wjWoglMYXBE

I've followed this tutorial to the T and my end result is not showing properly for some reason. Any idea why this could be?

I have looked at the numerous times this has been asked on here and google but I'm at a loss now.

My end result is image 1, what I'm aiming for is number 2 and my compositor node setup is 3.

If I hook the last node up to viewer instead of composite it just displays a solid colour..

enter image description here

enter image description hereenter image description here

$\endgroup$
  • 1
    $\begingroup$ so, if number 2 is your desired result it's basically the car object, lit but without the ground shadow, overimposed to the background image? $\endgroup$ – m.ardito Jul 21 '17 at 16:18
1
$\begingroup$

I don't know if I got what you wish, but for a simple object-over-background you could use something simpler like this:

enter image description here

[edit: I added another node setup, as suggested by cegaton, you can see both give same result in the two UV/image panels above/right]

note: without linking to the compositor node, imho you get no compositing in the final render...

$\endgroup$
  • 1
    $\begingroup$ For layers with alpha channel is less confusing to use the Alpha Over node instead of the mix node. i.stack.imgur.com/tiWXQ.png $\endgroup$ – user1853 Jul 21 '17 at 16:40
  • $\begingroup$ @cegaton added "alpha over" way too... but I'm not sure he meant this simple result, he has so many nodes... ?!? $\endgroup$ – m.ardito Jul 21 '17 at 16:53
  • $\begingroup$ The main issue on the OPs setup is that he/she is not using alpha at all. Probably Film>Transparency has not been enabled or he/she is using a solid background precluding the use of alpha. In my opinion this would call for a shadow catcher an no geometry around the object. $\endgroup$ – user1853 Jul 21 '17 at 16:57
  • $\begingroup$ OK, I'm getting there now, thank you for the above.. I just have 1 slight problem now, how do I get rid of the plane from the image but keep the shadow?: imgur.com/xLDet1R I just basically need the bed to look like its sitting in that room but with the ability to add more objects to the scene later on. $\endgroup$ – Callam Warner-Billington Jul 21 '17 at 18:40
  • 1
    $\begingroup$ @Callam Warner-Billington I guess that solution would work, buf if I was in you I would download the current pre-release (candidate) version of 2.79 and use the real "shadow catcher", since it's simpler. About marking a "correct answer", you should judge if it really answers your question, which was: "Can't get background image to show in cycles render" and you didn't particularly ask about overimposing the shadow to the image...? Anyway, is not that important :) $\endgroup$ – m.ardito Jul 23 '17 at 9:21
0
$\begingroup$

Try checking if you have enabled all the objects you want to see in the render in the outliner (top right box) and see if all the 'camera buttons' are highlighted.

$\endgroup$
  • $\begingroup$ I've added some more information as an answer by mistake if you want to see. Thank you! $\endgroup$ – Callam Warner-Billington Jul 21 '17 at 16:28
0
$\begingroup$

It looks correct to me? I've tried re downloading the image and re-saving it as a jpg too so I don't think its corrupt.

Do you think I need world settings in place for it to show properly? It just shows a black backdrop where the background image is supposed to be in the render.

enter image description here

At this point in the guys video [4:03], mine looks like this:

enter image description hereenter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.