2
$\begingroup$

I can't get the entire base of the walls to extrude upwards in order to finish modeling this house. Additionally, the areas that are already extruded are areas that I did not wish to be extruded and I can't figure out how to reverse it.

House Layout:

enter image description here enter image description here

Blend file:

$\endgroup$
  • $\begingroup$ Did you try W > Remove Doubles before extruding? It looks like you have extraneous faces at your edges. $\endgroup$ – Shady Puck Jul 21 '17 at 1:05
  • $\begingroup$ Yes, it said there were 0 doubles. That was the first thing I tried. $\endgroup$ – Dustin Sexson Jul 21 '17 at 1:09
  • $\begingroup$ Can you upload your .blend to Blend Exchange and paste the link into your question? $\endgroup$ – Shady Puck Jul 21 '17 at 1:12
  • $\begingroup$ I'm not sure how to do that. I'm still new to this site. $\endgroup$ – Dustin Sexson Jul 21 '17 at 1:13
  • $\begingroup$ Instead of extruding, use bridge edge loops to connect the parts you want. $\endgroup$ – cegaton Jul 21 '17 at 1:13
2
$\begingroup$

Alright, first things first. Let's identify your problems, which I did after a couple minutes.

Problems

  • You can Remove Doubles to remove 4,332 vertices.
  • Your bottom area has a tiny amount of thickness, which is preventing Extrude from working correctly.
  • Normals are all over the place.
  • Some faces are missing.

Solution

Beginning from your uploaded .blend file.

  1. Begin by keying A twice to select everything and key W > Remove Doubles.
  2. Enter Front Orthographic View by keying Numpad 1 and Numpad 5. This will allow us to remove the top and few walls that extruded correctly.
  3. Key Ctrl + Tab, 3 to enter Face Mesh Select Mode and Z to enter Wireframe View. Key A to deselect everything. Face select mode allows us to select the correctly extruded middle faces. Wireframe allows us to select vertices that are obscured by other parts of the mesh, rather than just the faces we can see.
  4. Use Box Select to select these faces: enter image description here
  5. Key X and select Faces to delete these faces. If you zoom in very close on the bottom, you can see its thickness: enter image description here
  6. Key Z to exit Wireframe View and return to Solid View. Key Numpad 7 to enter Top View.
  7. Box Select the entire grid. Because you are in Orthographic Solid View, only the top faces will be selected.
  8. Key X and select Vertices to delete all top vertices. This will remove the mesh interference.
  9. However, if you try to extrude now, you may get weird glitches. You must select everything with A and use Ctrl + N to Recalculate Normals.
  10. You may want to Fill in some faces now. enter image description here
  11. You can now use E to Extrude up on the Z-Axis.
  12. Select everything with A one last time and use Ctrl + N once again to finish touching up Normals.

Finished Product:

enter image description here

$\endgroup$
2
$\begingroup$

You have tons of duplicated vertices.

In edit mode select all and press remove doubles.

enter image description here

Then delete the top part of the model.

Then on the bottom part you can see that the mesh has already been extruded. So I'm going to presume that the top layer you can do without. In top solid view select the top faces and delete them.

enter image description here

Now you can extrude.

enter image description here

$\endgroup$
2
$\begingroup$

You've got yourself into a sticky situation here. First off, you may want to remove doubles by hitting "W" in edit mode then selecting "Remove Doubles". You can alternatively find this setting in the toolshelf (toggle by pressing "T"). Second, some of your normals are facing the wrong way, which can affect extruding. Recalculate them by selecting all in Edit Mode then by pressing "Ctrl + N". Third, you've already extruded the layout, so selecting all then extruding won't work. Select only the top faces by going to the top view (NUMPAD 7) and Orthographic mode (NUMPAD 5) then box selecting by pressing "B" then clicking and dragging to make a box over the entire layout.

enter image description here

You can exit Orthographic Mode (NUMPAD 5) and top view at this point. Now, since the model is already extruded, you can just move the top layer along the Z axis by pressing the blue arrow or by pressing "G" then "Z". However, you can still extrude it if you'd like, it would just create more polygons, thus extending render times a bit.

enter image description here

Hoped this solved your problem. Happy blendering :D

$\endgroup$
-2
$\begingroup$

From personal experience, I suggest you switch to edge select mode. That should do the trick.

Hope this helps!

$\endgroup$
  • $\begingroup$ Thank you! How do I deselect ignored to actually extrude the faces making a physical 3-D object? When I hit (E) it seems to actually Duplicate the object. $\endgroup$ – Dustin Sexson Jul 21 '17 at 0:52
  • $\begingroup$ What do you mean? $\endgroup$ – HappyBlenderUser Jul 21 '17 at 0:55
  • $\begingroup$ If I select on individual section of the mesh and extrude it creates a proper extrusion, but extruding all seems to only extrude a few places and duplicate the rest. Like in the original photo. $\endgroup$ – Dustin Sexson Jul 21 '17 at 0:56
  • $\begingroup$ Even in edge select mode? $\endgroup$ – HappyBlenderUser Jul 21 '17 at 0:58
  • $\begingroup$ Can you send me the .blend file? $\endgroup$ – HappyBlenderUser Jul 21 '17 at 0:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.