1
$\begingroup$

I would like to emit particles from the boolean intersection between a cube and an irregularly shaped object. The end result is like this:enter image description here

So, I need to emit particles only from the yellow area. The particles are a group of tiny rocks, they need to be randomly emitted. I tried using the grease pencil to select certain areas (creating a bezier curve from pencil), but this would get time-consuming really fast, and besides, I could not get it to work. Note: I asked a previous question to create the cube, here was the methodology: Previous Question

EDIT 1: Here's the file link: Link.

$\endgroup$
  • $\begingroup$ I'd try selecting a face in every face of the cube and, select similar -> coplanar or normal with a very small threshold. If that doesn't work please upload the cube. $\endgroup$ – Firewill Jul 20 '17 at 16:26
0
$\begingroup$

Easiest way would be to just select all faces with the yellow material in Edit Mode, there is a button under the Material Slot list to do that, and duplicate them.

Separate those duplicate faces into a new object and add a particle system to it. You can make the Emitter invisible to rendering, and also make it wireframe in the viewport.

Another way is to use Vertex Groups. Just select the yellow faces as above and create a new Vertex Group to which you add the selected vertex. You can then use that vertex group to influence the particle emission by assigning it ti the Density field in the Vertex Groups section under the Particle system settings.

Have in mind that Vertex Groups are not an unequivocal way to define face selections, so some "bleeding" is expected if you select all vertex.

Also see Assign Particle System to parts of a mesh

$\endgroup$
  • $\begingroup$ selecting using the materials tab does not work. Despite the yellow faces being rendered, clicking select on the "yellow" material selects 0 faces. Whereas, selecting "White" selects all faces. Selecting faces on the cube object has no effect either. $\endgroup$ – student Jul 20 '17 at 18:31
  • $\begingroup$ You have to apply the Boolean modifier first. $\endgroup$ – Duarte Farrajota Ramos Jul 20 '17 at 18:38
  • $\begingroup$ Yes, I have already applied the boolean modifier, selecting using the materials tabs still does not work. $\endgroup$ – student Jul 20 '17 at 18:52
  • $\begingroup$ Could you provide a file we can look at? $\endgroup$ – Duarte Farrajota Ramos Jul 20 '17 at 19:08
  • $\begingroup$ Edited the question to provide the link to the file. $\endgroup$ – student Jul 20 '17 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.