0
$\begingroup$

I often have a problem when lighting where to see the sharp edges on the mesh. This happens when I add any bump & when I use Lamp as a light source. And the darker the scene & the stronger bump, the more visible these edges, even when the object is smoothed. Please help with this problem. Because of this it's impossible to make quality works.

enter image description here

$\endgroup$
1
$\begingroup$

It really depends on how you're applying your bump.

If you're doing it via the new "True" displacement (or "Both") settings in Cycles materials, your mesh should be adequately subdivided in order for it to work properly. The displacement is indeed applied on the actual geometry (vertices) of the mesh, not on its faces.

To do so, try using the Subdivision Surface modifier with an adequate level of subdivision or, if you're using the experimental features on a recent version of Blender, you can make it adaptive: reference.

Also, increasing the lamp size parameter could help.


enter image description here

(the black spots in the last one are because I didn't put too much care in creating a seamless UV map, and a fine subdivision, together with a strong bump value, makes it more evident)


Related: Blender Cycles True Displacement

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Amazing explanation. $\endgroup$ – TeaCrab Jul 20 '17 at 14:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.