1
$\begingroup$

I'm using the Molecular Script add-on to create particles to fill a container. It's working well provided the particles aren't rotating. As soon as I add rotation, those that collide with the surface rotate as expected (with friction with the surface) and those that bounce off of each other also seem to rotate as expected, but those that become 'at rest' in the centre of the mass of particles continue to rotate - I would have expected friction with the neighboring particles to cause them to stop rotating.

I end up with something like the following :

animated particles - spinning

I've tried all the particle settings (including Damping, Drag, Molecular Linking, etc.) but nothing appears to enable friction between these 'at rest' particles. How can I get my particles to stop when at rest?

Here's the full particle properties panel (apologies for the very tall image!) :

particle settings

EDIT

I've tried disabling the Dynamic option as suggested by Mateus but this stops all rotation - including rotation when rolling on the collision surface.

I'm wondering whether Molecular Script does not handle rotation at all - since on closer inspection the particle to particle collisions don't actually seem to be producing rotation either - and what I was seeing was the rotation from surface collision interactions only.

Blend file provided :

$\endgroup$
  • $\begingroup$ I always set Friction under Molecular Script settings around 0.4~0.6 to stop them rotating/jittering. Try this value or provide blend file, so I can inspect it further. $\endgroup$ – cgslav Jul 19 '17 at 23:51
  • $\begingroup$ Try to uncheck the 'dynamic' option on rotation tab. $\endgroup$ – Mateus Itiyama Jul 20 '17 at 1:58
  • $\begingroup$ You need only a couple of ticks @Rich Sedman . Select the bowl, goto it's physics properties, give it collision and down in the "Collision" tab, tick "Kill Particles". This would normally make particles disappear once 'dead' so we goto the emitter and get to it's particles properties and open it's "Render" tab, tick "Died". Dead particles will now be displayed. On collision with the bowl they stay visible and whatsmore, stop wriggling about! If those heaped up in the center are still 'alive' give the emitter or the emitter object the same treatment. (someone else's idea btw) $\endgroup$ – Edgel3D Jul 20 '17 at 2:32
  • 1
    $\begingroup$ Sorry for the late answer, it actually seems (as you have noticed it) that Molecular Script doesn't support Dynamic Rotation. Collision objects are stopping rotation as they should, but in MS even strong particle linking doesn't prevent them to rotate. $\endgroup$ – cgslav Jul 21 '17 at 11:47
  • 1
    $\begingroup$ @user3800527 The damping only affects the velocity, not the rotation. $\endgroup$ – Rich Sedman Jul 25 '17 at 8:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.