2
$\begingroup$

I Was watching "How to make a Lightsaber in Blender | The easy way" where it taught me how to make a lightsaber using a mask. Towards the end of the video,I clicked render animation and when i checked my output file, the pictures had no mask around them. I used a image sequence.

My render result is thisenter image description here

$\endgroup$
  • $\begingroup$ At the bottom where it has the checkbox for background, there is a "Use Nodes" checkbox to the left of it. $\endgroup$ – Anson Savage Jul 19 '17 at 17:49
  • $\begingroup$ I have already checked the "use nodes" checkbox. $\endgroup$ – Charan Kotha Jul 19 '17 at 19:00
  • $\begingroup$ I added a Full picture of my blender screen. $\endgroup$ – Charan Kotha Jul 19 '17 at 19:02
  • $\begingroup$ Do you mean the checkbox in the picture above. I think it is renderable $\endgroup$ – Charan Kotha Jul 20 '17 at 0:28
  • $\begingroup$ Yeah, looks good, IDK what your problem is then. What does the backdrop look like? $\endgroup$ – Anson Savage Jul 20 '17 at 2:13
1
$\begingroup$

Possible solutions:

  1. Make sure you have your mask selected from the drop-down in the Mask node
  2. Make sure your output is not only connected to the Viewer node but also to the Composite node output. Ensure that "Use Nodes" at the bottom of the Node editor is checked.
  3. Make sure the mask layer you are using is enabled to render

Please update with more information if this does not solve your problem.

| improve this answer | |
$\endgroup$
  • $\begingroup$ The weird part is I can clearly see my blade in the node editor. And what do you mean by "Make sure your output is not only connected to the Viewer node but also to the Composite node output. Ensure that "Use Nodes" at the bottom of the Node editor is checked." $\endgroup$ – Charan Kotha Jul 19 '17 at 15:22
  • $\begingroup$ @CharanKotha In the Node Editor, you will see the backdrop that is connected to the "Viewer" node at the end of your tree. For your nodes to be rendered, you must connect this same output to a "Composite" node. If you don't have one, add one with Shift + A > Output > Composite. $\endgroup$ – Anson Savage Jul 19 '17 at 16:12
  • $\begingroup$ That is how my node editor looks like, but i just turned off the backdrop. $\endgroup$ – Charan Kotha Jul 19 '17 at 16:31
  • $\begingroup$ "Make sure the mask layer you are using is enabled to render" How do I do this. $\endgroup$ – Charan Kotha Jul 19 '17 at 22:33
  • $\begingroup$ What do you mean by "Make sure the mask layer you are using is enabled to render". $\endgroup$ – Charan Kotha Jul 19 '17 at 23:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.