3
$\begingroup$

Let's say I have several objects and I want to parent them to a plane that has an ocean modifier on it. The problem I'm having is that the objects move as a group instead of independently of one another. So if I have a sphere, a cone, and a cylinder and I want the ocean to consist of these objects, I would like them to all be a part of the ocean and move independently of one another, but I get one of two results:

1). The block of objects do not move independently, they move as a block

2). I can get independent movement, but only if I delete object by object until I realize I'm just down to one.

I've tried to parent objects to individual vertices, but it didn't work.

Here are the steps I followed:

  1. Line up all objects in the order I want them

  2. Select all objects and select plane last. Parent objects to plane (ctr + p) (I've also tried going into edit mode on the plane and parenting one object to one vertices)

  3. Under the object panel, I used Duplifaces to duplicate according to vertices (I've also tried faces)
  4. I added an ocean modifier to the plane, set my resolution, depth, etc

But all objects move together as a bunch of small groups. This first image shows an example of how I might want the line-up/order to be. The second image shows a what this looks like if I parent the objects to the verts. Notice that they move in groups. The only way I can hide it is by making the resolution really high, but that is going to cost me in verts/rendering load.[![Objects I want moving independently][1]][1] [![enter image description here][2]][2]

Edit: Duarte's solution down there works very well, but there's one issue in that the objects overlap one another. I'm using a 4x4 group and have the following settings/followed the following steps:

  1. Create plane
  2. Modify the plane with an ocean modifier
  3. Group target objects together (I'm using a 4x4 configuration)
  4. Add particle system
  5. Under Particle System > Emission add a high number (I chose 5,000). Also, select "Verts" and tick the box for Use Modifier Stack
  6. Under Particle System > Render: tick boxes for "Unborn" and "Die." Also, the target group in the "Dupligroup" field
  7. Under the Ocean Modifier, mess with settings to suit your project. (I've got my resolution at 4, choppiness and scale are at 1, smallest w at .01, wind velocity at 30). The biggest thing here to mess with is probably the resolution.

I have three unique objects and it looks like they are overlapping and I can't figure out how to keep them from doing so. I mess with resolution, tick on and off things like global, but no luck. Here's an image of the current issue. You can see the image highlights both a blank space and a space where objects overlap. Edit: just kidding, Stack exchange won't let me post a third photo because my reputation is less than ten, so... you'll have to go off of description.

$\endgroup$
  • $\begingroup$ My first instinct would be to use python to create thousands of objects whose location has drivers referring to the vertex locations, but I have not yet discovered if that information is exposed via the python API. If you get desperate enough you could bake the ocean and pull the data from the baked EXR files (handwaving) and use it to generate keyframes for thousands of individual objects. $\endgroup$ – Mutant Bob Jul 18 '17 at 19:19
6
$\begingroup$

Use a particle system for your objects instead.

enter image description here

Create you ocean with whatever method you like (Ocean Modifier I suppose). Add a particle system to it, make it emit from vertex and turn on Use Modifier Stack.

Under the Render settings make it use a group, then point it to a group containing all your objects. If you want them ordered just leave settings as is, if you want random positioning just tick the option Pick Random

enter image description here

Turn on the Unborn and Died option so all are visible.

Turn off the Random option (right bellow Vertex) so only one object is used per vertex, then check in the 3D View header under Object Mode how many vertex your object has, then adjust the particle count to match it exactly, so no wholes or overlaps happen.

enter image description here

$\endgroup$
  • $\begingroup$ This solution is awesome and only has one issue that it leaves left over (which might be due to me poorly following instructions). I noticed that your screenshot says 5,000+ in the number field. I put in a large number but noticed that what happened was that the if you look from above, there are holes where no object exists. As you increase the number, the holes get filled in. However, what is also happening is that objects overlay on top of one another. I played around with my starting group (it's a 4x4), but the problem persists. $\endgroup$ – Jake Mabey Jul 18 '17 at 23:57
  • $\begingroup$ Hum I forgot to mention it it but if you check the last image with the particle system settings it is there, just uncheck the Random option. Answer edited accordingly $\endgroup$ – Duarte Farrajota Ramos Jul 19 '17 at 0:09
  • $\begingroup$ That helped, but I had already played with that. Here is the file. dropbox.com/s/srfex6d8f939xlv/… $\endgroup$ – Jake Mabey Jul 19 '17 at 0:48
  • $\begingroup$ You file looks quite messy, there several unnamed groups containing lots of duplicate objects and dozens of similar "Phospholipid" objects overlapping in place. Sounds like it is time for some cleanup and organization. $\endgroup$ – Duarte Farrajota Ramos Jul 19 '17 at 1:07
  • 3
    $\begingroup$ You need the emission number to be equal to the number of vertices in the mesh generated by the ocean modifier to not get any gaps or duplicates. Also under physics, select "No" so that they don't fall away in an animation. $\endgroup$ – sambler Jul 19 '17 at 3:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.