1
$\begingroup$

Over the past few weeks, shortly before 2.7 and during 2.7, I've been having trouble with various hotkeys and mouse controls.

Occasionally,

  • LMB will not grab a transform axis to manipulate objects, but it will only relocate the 3D Cursor.
  • Numpad controls go from changing view to switching layers.
  • Many other controls, such as Ctrl+ and Ctrl- for growing and shrinking selections, refuse to work or work differently unless I press or hold the Esc key first.

The interesting thing is that this doesn't happen constantly. When I start a session of modeling, controls work normally, but at some random point during the session the controls will flip over to what I described above.

$\endgroup$
1
$\begingroup$

ESC Required

One possibility would be that you've accidentally activated a selection or an operator awaiting further input?

In this case the Header of your 3D View might change to something like:

enter image description here Example for Knife Tool

ESC would cancel such operations.

Possible Solution

On Windows you can have different keyboard layouts and switch between them by pressing Left Alt-Shift which happens very easy when using Blender. If this is the reason change the Hotkeys in Windows: Control panel / Region & Languages / Keyboard & languages / Change keyboard / Advanced key setting

Numeric Input

On my machine the numeric block is independent from whether or not the NumLock is active it never switches the layers as the normal digits would do. The option Emulate Numpad in the User Preferences / Input would make the main keys 1 to 0 to switch the Views Orientation. But it's never the other way around.

$\endgroup$
  • $\begingroup$ Thanks, stacker. It happens when I have nothing activated or selected, but doesn't seem to mess anything up when I do have a command active. I tried the left-alt+shift and didn't see any change. It's very strange. I also made sure emulate numpad wasn't checked just in case that somehow was messing things up, but it wasn't. Thanks for your reply, though. $\endgroup$ – user3092 Apr 13 '14 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.