I installed blender for the first time, so I have the latest version, 2.78c.

I played with it for a bit. Then I discovered I couldn't save my work.

I uninstalled it and reinstalled it. Rebooted. Same problem.

After a little testing, I realized I CAN save to my NAS storage drive. I cannot save on my C: drive. Any project. Any folder. C: always fails.

If I run blender as Administrator, it will save to the C: drive. But not as my normal userid. So it sounds like a bug of some kind.

I am running Windows 10. Bitdefender A/V. I use OneDrive. I have a 2TB drive installed. All clean and purring nicely.

Is there a better way to install it? Or some change I can make (other than always running as administrator)?

Sounds like a bug - but hopefully there's a proper solution.

Thanks, Jerry

  • 1
    $\begingroup$ If it is a bug then it should be reported to the bug tracker, nothing we can do about it here, but since no one else seems to be reporting that issue my guess is it is something about your system. "All clean and purring nicely." it is not clean, there is an antivirus software polluting your system, have you tried disabling it or seeing if it is blocking Blender somehow? $\endgroup$ – Duarte Farrajota Ramos Jul 16 '17 at 1:20
  • $\begingroup$ In my case, I am saving to my OneDrive folder. All my documents are there. After further testing, I discovered that I CAN write to my actual my documents folder, but not to any other location. This is something blender is forcing. It's not a windows permissions issue. Therefore it's a bug but affects only people who don't use "My Documents", like myself. So I have my work-around and I will report the issue to the bug tracker as well. Thanks for your help. $\endgroup$ – Jerry Jul 16 '17 at 1:32
  • 4
    $\begingroup$ I'm voting to close this question as off-topic because this doesn't seem to be an issue with Blender $\endgroup$ – Duarte Farrajota Ramos Jul 17 '17 at 13:26
  • $\begingroup$ did you use the installer or the zip file? $\endgroup$ – David Jul 18 '17 at 2:25
  • $\begingroup$ Duarte. It is an issue with Blender. I did report it to the bug reports. Blender does not honor the windows file/folder permissions systems. We can close this, but the issue is that everyone just runs as administrator to overcome the issue instead of dealing with the issue itself. Want to test it? Run blender as a normal user and try to save a file to anything outside of your my documents. Even if you have full permissions to do so, blender will not do it. That's a bug. Anyway, I reported it. Thanks for your input. $\endgroup$ – Jerry Jul 18 '17 at 2:28

Windows 10 requires Administrative right for saving files to the C: drive. However you can save in your Documents folder, its also stored on the C: drive.

  • $\begingroup$ In my case, I keep all my documents on OneDrive. If I save to any folders inside my OneDrive folder, it fails. If I try to save to c:\ or other places, it fails. However, based on your suggestion, I tried to save directly into "My Documents", which I never use for anything. It DOES write there. So apparently blender is specifically forcing this save location and is not actually using Windows integrated permissions settings to determine where files can be saved or not. Basically, you did solve my problem. But I will also report this as a bug. $\endgroup$ – Jerry Jul 16 '17 at 1:29
  • 1
    $\begingroup$ @Jerry If this answer solved your question you should consider accepting it. See: stackoverflow.com/help/someone-answers $\endgroup$ – Ray Mairlot Jul 16 '17 at 11:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.