0
$\begingroup$

I've got a problem with lighting. I don't want lights that gets through edges :/ I have closed room with floor, ceiling and walls. Point light object is created upper ceiling. And light gets inside the room but it should not. How to fix this? Room should be dark but is bright because of light object :/

Closed room with point light object above ceiling

Light gets inside

$\endgroup$
1
$\begingroup$

You have to go to the lamps properties > "lamp icon" > "Shadow" > enable "Ray Shadow" to get this fixed:

Enabling ray traced shadows for this light source Enabling ray tracing in general for the whole scene

Cheers

$\endgroup$
  • $\begingroup$ Oh, thanks! Btw, do you know how to do that with glowing objects? Here's the link that shows how it look like: youtube.com/watch?v=jrNks470FRk $\endgroup$ – TheAndroidPL Jul 15 '17 at 11:12
  • 1
    $\begingroup$ Note that this won't work if Ray Tracing is not enabled in the Render tab > Shading rollout. This increases the render time as well. $\endgroup$ – Mr Zak Jul 15 '17 at 12:33
  • $\begingroup$ Thanks for pointing that out, @MrZak, I just edited my post I don't know wether Blender (internal) Render is capable of handling ray traced shadows for emitting objects, however, Blender Cylces is. Just make the same setup as in your example, set click "Use Nodes" in the Material tab of the emitter and set "Emission" in the under "Surface" > "Surface". If you really want to get into Cycles watch the beginner tutorial series of BlenderGuru at [link] blenderguru.com/tutorials/blender-beginner-tutorial-series $\endgroup$ – Ignatiamus Jul 15 '17 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.