1
$\begingroup$

I have a frequent problem where I separate out multiple blender windows onto my secondary screen. These are usually node editors and UV/Image viewer windows.

When I re-open blender, often these secondary windows come up as solid black and cannot be restored. They are also moved back to my primary monitor. This never occurs with the primary 3D editor window.

It is not a big deal, but it is yet another small hassle that I'd like to fix. Is there a cause for this? Is there a way to restore the window to what it was without closing and re-creating it?

I am on Windows 7.

$\endgroup$
  • 1
    $\begingroup$ This is most likely an issue with either graphics drivers, GPU or both. Have you tried playing around with different drawing methods in the system user preferences? Some of those might work better than others for certain graphics cards combination. $\endgroup$ – Duarte Farrajota Ramos Jul 15 '17 at 2:19
  • $\begingroup$ @DuarteFarrajotaRamos I have not. Would that be after I get the issue that I should try different settings? Also, I can confirm that I've had this issue for years, and across three different graphics cards. I'd had it when both screens were running on the same card, and when they are on different cards. $\endgroup$ – Drudge Jul 15 '17 at 3:48
  • $\begingroup$ You should try before the issue manifests. Set one as default, save settings restart and run Blender normally. If the issue doesn't show again with the new settings then congrats you've solved your problem. If it still does then repeat process with a different one. I've been using a multi-monitor setup with multiple Blender windows ad never encountered that issue, so something is wrong there. $\endgroup$ – Duarte Farrajota Ramos Jul 15 '17 at 4:05
  • $\begingroup$ @DuarteFarrajotaRamos I'll give it a try. But the issue is so intermittent that it will be tough. Thank you! $\endgroup$ – Drudge Jul 15 '17 at 4:11
  • $\begingroup$ You might try making a backup of your startup .blend, then reset to defaults, then save the defaults as your new startup.blend. Try using the default settings for a while and see if the issue still arises. $\endgroup$ – Mentalist Jul 15 '17 at 5:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.