0
$\begingroup$

I am using the Texture Atlas to combine UVs from multiple objects, all of which have UVs already unwrapped and laid out. To do this I am adding the objects to the atlas and then using the 'StartManualUnwrap' button. This is all following the CGCookie course on 'shading a scifi helmet'.

When I do this I get the following error:

Traceback (most recent call last):
  File "C:\Program Files\Blender 
Foundation\Blender\2.78\scripts\addons\uv_texture_atlas.py", line 214, in 
execute
    group_name=group.name, unwrap=False)
  File "C:\Program Files\Blender 
Foundation\Blender\2.78\scripts\modules\bpy\ops.py", line 189, in __call__
ret = op_call(self.idname_py(), None, kw)
RuntimeError: Error: Traceback (most recent call last):
  File "C:\Program Files\Blender 
Foundation\Blender\2.78\scripts\addons\uv_texture_atlas.py", line 673, in 
execute
    bpy.ops.object.join()
  File "C:\Program Files\Blender 
Foundation\Blender\2.78\scripts\modules\bpy\ops.py", line 189, in __call__
    ret = op_call(self.idname_py(), None, kw)
RuntimeError: Operator bpy.ops.object.join.poll() failed, context is 
incorrect

location: C:\Program Files\Blender 
Foundation\Blender\2.78\scripts\modules\bpy\ops.py:189



location: <unknown location>:-1

Does anybody have an idea why this is happening?

I tested by just adding two of my objects to the atlas, rather than all of them, with the same outcome. I also tried starting a new blend file and unwrapping two cubes, combining them with the atlas and then performing the manual unwrap. This worked fine.

Thanks in advance.

$\endgroup$

1 Answer 1

0
$\begingroup$

I worked around this by starting a brand new blend file and appending all my objects from the old file.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .