0
$\begingroup$

I understand that this type of question has been asked at least 50x, but please read me out.

This is as simple as it gets: Freestyle is not rendering in the final render. It simply does not work. Yes, I know this question already exists, but despite checking to make sure no settings were touched, despite trying this with a simple cube, it does not work. The "Include" option is running, not "Exclude".

enter image description here

I understand this is really ridiculous, but may I ask just what I am missing? I have previously used 2.79 builds, but I am not sure if that affects 2.78c, if that means anything. Please note that I am currently attempting this with Cycles, in case this ruins the whole thing.

$\endgroup$
  • $\begingroup$ Here are the current settings: imgur.com/41k8LWM imgur.com/4tV43dF What do you mean, enabled in Rendering? I turned on the checkmark, if that is what you mean. ...If I sound like an idiot, I would completely understand, I just feel so blind, right now. $\endgroup$ – Darknaviexe Jul 12 '17 at 15:37
  • $\begingroup$ imgur.com/UNm6mGe No modifiers until this: imgur.com/RrTm6Ei How do I find out about the mesh being used for lines? I tried it with the cube, nothing worked, no settings changed. imgur.com/mJelp21 $\endgroup$ – Darknaviexe Jul 12 '17 at 17:46
  • $\begingroup$ If you tried with default cube then the mesh is suitable for freestyle. As I get it seems to not work if default file is opened and rendered default cube (pressing F12 to render) with default freestyle settings. In that case this might be a bug in this Blender version, check if there are newer versions available and try them. $\endgroup$ – Mr Zak Jul 12 '17 at 18:19
  • $\begingroup$ I have tried today's Blender build. Nothing. It did not work. I have no idea if this is related to my computer or it's settings, or even that I used 2.8 builds, causing problems in the process... $\endgroup$ – Darknaviexe Jul 12 '17 at 19:51
  • $\begingroup$ Can you upload the file? The last step would be to file a bug report at bug tracker as you tried the latest build and didn't get freestyle. $\endgroup$ – Mr Zak Jul 12 '17 at 20:13
1
$\begingroup$

I am not sure if this is a bug, though it likely could be, as I had recently discussed with user "Mr Zak". The idea is to save the file, even though "Freestyle" is checked in the Render tab, then reopen the file. You may notice "Freestyle", in the Render tab, is now unchecked. ...Strange, huh? Check Freestyle again, then render it. Confused? So am I. However, this is the current working solution, and while Mr Zak pointed out he was using 2.78a, I am currently using 2.78c, at the time of this post.

Edit 6 days 55 minutes later: I feel like an idiot, but I needed a minute in Blender's Discord to find out the fatal mistake: ...Pressing the wrong render button. ...You read me correctly, I was pressing the wrong render button, this entire time!

Wrong Render Button

This is the button I have been using to render, this entire time. As the locals in Blender's Discord have informed me, a detail I have been overlooking for too long, much less to begin with, this renders OpenGL. That means you will be given a render of exactly what you see in the viewport, completely different from when you look in rendered view.

Correct Render buttons

The buttons circles in this picture here, are the buttons you should be using for final renders, as opposed to OpenGL giving simply previews. That means that the button circles in the top-left section and the button circles on the right-hand side act as final render buttons, the equivalent of pressing F12 on your connected keyboard. Meanwhile, pressing the button underlined in this picture, and pressing the button depicted in the previous picture, will render only what you see in your viewport. If you want to see Freestyle lines, as I have been seeking, you want to use F12 render.

In case anyone is wondering, I have been asked if I had messed with the keybinds. I am not sure if this has anything relevant to do with it, but no, I did not mess with the keybinds. I have simply been blindly using the OpenGL render instead of F12's render, believing to have achieved the same results. I hope this proves educational and informational to anyone else who would ever make the same mistake I have made.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.