1
$\begingroup$

Basic Background

So, I was in very early stages of some modeling I was creating as a favor to a company called "Atomz Lab". I was to create and 3D print their mascot (A young boy wearing an atom T-Shirt, holding a graduated cylinder full of a orange substance).

It was essentially something I could add to my portfolio.

But very early on, while I was still working on the basic shape and detail of the head, I ran a quick test, to see if the hair would export like in material mode, or how it did post render.

The Problem

After converting the particle system into a mesh and exporting it as .obj and .mtl files, I loaded it up into 3D Builder, only to find just the head. My hair object was gone. After several other attempts, I finally gave up and decided to post this for answers.

I believe the problem could either be contributed to the limitations of 3D Builder, or that Blender exports converted meshes from hair particles in some sort of format only it can read.

Here's some screenshots: enter image description here

After exporting the .obj and .mtl files, I opened them up in 3D Builder.

This is what I found: enter image description here The hair disappeared!

I really need some help. If any of you know the answer, on how to bring converted meshes into 3D Builder, please let me know.

$\endgroup$
1
$\begingroup$

Looking at the reference image I'd say it could be better to model that hair via simple mesh without any particle system. This way is often used for hair in some styles of 3d and 2d art, it allows to avoid possible slowdowns of particle system as well.

As to converted particles probably you used Path option as how particles are rendered in the Render layout of the particle system settings.

enter image description here

After applying Particle System modifier they become simple lines (edges with no thickness) which can't be printed because they are non-manifold geometry.

One way is to make that geometry manifold is to solidify it using Skin modifier on converted particles.

Select object with converted particles (note that you might want to leave particle system undeleted but hidden in case some changes are needed). Add Skin modifier to it. By default modifier will solidify only one of converted particles because it marked a vertex as root for only one edge while it needs one root vertex for all the connected pieces of geometry. As per manual:

Mark Root
Marking a vertex as root causes that vertex to be used for calculating rotations for connected limbs. [...]
Each set of connected vertices should have one root node.

The easiest way to mark one vertex for multiple edges of the converted particles is to enter Edit mode, select all and press Mark Root button. It will find one vertex itself to mark so no need to deselect anything.
Once done all the particles will have thickness and become manifold, all-quads geometry. Make sure to apply modifier if exporting mesh.

scr-progress-of-fattening-particles-hairs


Another simple and working a bit differently solution is to set Object as how particles are rendered in Render rollout instead and give it some thin and long cube as object to be used as hair particle to make particles based on it. See underlined option on the 1-st screenshot, change it to Object and choose cube you created. No need to make follow it anything, it will be done automatically.

Make sure to rotate base mesh accordingly so it's oriented accordingly (e.g. outside of the mesh, typically you will need to rotate it along X axis).

This way is less flexible and gives slightly different result as it doesn't allow e.g. Brownian Motion setup to change particle orientation along its local X and Y axis, only along Z, and other options which allow to randomize particles.

$\endgroup$
  • $\begingroup$ Okay, so about the Object hair particle. How do I do that? I made the thin cubes, but I could only select one. I made them a group and swapped to group, but the hair still didn't follow the cubes in any consistent matter I could find. I even created a bezier curve of the hair, converted to mesh, joined the vertices, made a face, and extruded them out.When I selected it, it just made a really weird hair style that didn't even fit on the sphere. None of my courses covered mesh hair, so I haven't the slightest clue on how to use them. YouTube isn't much help, either. @WKG $\endgroup$ – Daniel Everhart Jul 13 '17 at 4:08
  • $\begingroup$ @DanielEverhart no need to select more than one cylinder, one is enough for particle system. I added some details into the answer for this method and added another one with Skin mod. $\endgroup$ – WKG Jul 17 '17 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.