4
$\begingroup$

My RenderSo I've been working on this one scene for a while now and I just can't get the look that I want. It is supposed to be a bar and therefore pretty dark. For some reason, nothing I do seems to reduce the noise. I can't figure out if I need to increase the number of samples (I have it at 2000 right now) or what but nothing seems to be working. I really don't want to add more light to the scene because it has the kind of feel that want but I need to remove the noise somehow. Also, I need some advice on how to make it look more realistic. I am using Filmic Blender but it only goes so far. I'm using bump maps among other things to add realism but it isn't really working. Any advice is appreciated.

Thanks,

$\endgroup$
4
$\begingroup$

Unfortunately, there's not a way to get the render less noisy other than increasing the number of samples. One of the reasons for this is that most of the light in the dark areas is coming from indirect bounces. There are a few ways to clean it up though.

First, you can use Render Passes:

enter image description here

This allows you to edit individual passes such as Diffuse Indirect to try to blur the noise. This is pretty effective but it can also smear some detail if you're not careful. The main problem with this approach is the amount of "noding" you must do to recombine the passes. The good thing is that you can use Node Groups to make it look nicer [ Can I make a custom node from a group and have that available in other projects? ]

Here's the node tree for this. It's a lot simpler than it looks. Basically you just add the direct and indirect pass for each shader and then multiply it by the color pass for that shader. I made this node tree into a group:

enter image description here

The only purpose of this node group is to combine all the passes into the final image.



Use the Depth and Normal passes to create your Determinator for the Bilateral Blur node like so and feed them into the Node Group above:

enter image description here

At a minimum I usually use one Bilateral Blur node for the Diffuse and Glossy Indirect passes. This method gives that most control over denoising.



However, in the 2.79 Beta version, there's a new Denoising filter included with Blender that is quite effective: [ https://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.79/Cycles ]

enter image description here

It can use your GPU to calculate the denoising of tiles, too. The problem with this method is that it's processed as it renders. So if you don't like the options you've chosen, you have to render the entire scene again. That can get old really fast, especially if you have to wait ten minutes per render. It also adds significant time to your render but not as much as a comparable amount of samples. There can also be some artifacting in glossy shaders. I've found that in really noisy scenes (like the one below) that it can look splotchy. This can probably be improved with fiddling with the settings.

Here's a quick comparison of these two methods with a piece of a scene I've been working on. It has bump mapped walls and it's very dark, so it can be really noisy. In my opinion the Render Pass version looks the best and is much more versatile. But the Denoiser is easier to use. This scene was rendered at 800 samples. I've increased the brightness manually so you can see the noise better: enter image description here enter image description here enter image description here

$\endgroup$
  • $\begingroup$ Thank you so much! This is what I needed. do you think I can turn down the samples after adding this? $\endgroup$ – MrSchmuck Jul 12 '17 at 4:15
  • $\begingroup$ @MrSchmuck -That was my primary purpose in using it. I had hundreds of frames I needed to render for a video and I didn't have the time to render 10000 samples for each frame. If this solved your issue, please click the checkmark and mark it as accepted. If not let me know what I can do. $\endgroup$ – bertmoog Jul 12 '17 at 4:21
  • $\begingroup$ Absolutely. Let me just finish making the group and I'll accept it. $\endgroup$ – MrSchmuck Jul 12 '17 at 4:31
  • $\begingroup$ Im not sure if I did it right. Themath nodes in the group didn't have the texture icon like thay did in your example and it doesn't seem to have made a huge diferance $\endgroup$ – MrSchmuck Jul 12 '17 at 5:07
  • $\begingroup$ From the node editor, go to Add -> Search -> and type "Mix". It's a color mix node. Then, from the node drop-down box, select "Add" or "Multiply". $\endgroup$ – bertmoog Jul 12 '17 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.