11
$\begingroup$

I have made an object out of a cube, that I applied boolean and mirror modifiers. Now when I apply Bevel, I don't see anything. I want it to have slightly rounded edges and corners.

It doesn't seem to make any change if I disable the other modifiers or move Bevel higher up.

Here's what my object looks like: enter image description here

It works on a cube, and here's what I want the edges to look like:

enter image description here

Here's my blend file:

Appreciate any help!

$\endgroup$
5
  • 4
    $\begingroup$ It's not working because of bad topology. You have there huge ngons. $\endgroup$
    – cgslav
    Jul 11, 2017 at 9:31
  • $\begingroup$ Aha, is there any other way to round or fix the topology without modelling everything by hand? I assume it's the booleans that make this topology? $\endgroup$
    – Niclas
    Jul 11, 2017 at 9:33
  • 4
    $\begingroup$ Yes it's Booleans fault (as usual). You could try to use Remesh modifier but it will probably create mesh so dense that Bevel will not work as well. Modeling by hand could by only way to use nice bevel. Maybe also you could try using Subsurface modeling. It's based on your modeling purpose. $\endgroup$
    – cgslav
    Jul 11, 2017 at 9:56
  • $\begingroup$ Zoom very close and I found the Bevel is hapening but the Amount cannot be changed >0.00003 m. The other thing, not related to your problem here, Scale not applied, which also scaled the boolean. $\endgroup$
    – MA Jacob
    Oct 21, 2020 at 14:10
  • $\begingroup$ Make sure the normals on your faces are all pointing the right way. Boolean operators can sometimes leave you with faces pointing inside. $\endgroup$
    – kitfox
    Nov 5, 2020 at 12:55

5 Answers 5

10
$\begingroup$

Merge the vertices by distance and then it will work, just tested

$\endgroup$
3
  • 2
    $\begingroup$ Can you go into detail what precisely you need to do to do this, or why this works? $\endgroup$
    – Kirbinator
    Sep 25, 2020 at 18:23
  • 5
    $\begingroup$ For future Google-ers in Blender 2.9: In Edit mode, select everything. Go to the menu in the top left corner of the viewport. and hit Mesh > Clean Up > Merge by Distance. This will remove any duplicated vertices. Which, for some reason, I ALWAYS end up having. I'm probably doing something wrong. $\endgroup$
    – Andrew
    Jan 8, 2021 at 18:33
  • $\begingroup$ Oh Yea! Thats it $\endgroup$ Mar 2, 2021 at 20:05
9
$\begingroup$

I also came across this post. Turning off "clamp overlap" worked for me.

"Blender bevel modifier not working?" on YouTube and transcript (archived copy from Web Archive)

This was the relevant part of the post for me:

We can force bevel modifier to bevel the edges even though there are double vertices in our model by turning off this “clamp overlap” option in here. Let me turn this modifier back on. Basically this option, if it is on, will prevent the modifier to produce bevel effect if the result will look bad because they will overlap. The overlapping happens because the existing gaps between edges are too small. Notice if we have this option turned off. And let’s put smaller width value like 2 mm. At the glance the model looks okay. But once we get close to this area, we can see this ugly result. So now we know why this option is turn on by default. It is to avoid us from having these ugly topology result. So essentially turning off this option is doable but it is not the best solution.

Subsequently the author describes how to avoid the problem in the first place should you want to read further.

$\endgroup$
3
  • $\begingroup$ Hi :) It would be helpful to add the essential information from the link in your answer. If it ever goes down, then your answer will then be a comment :) See here $\endgroup$
    – Timaroberts
    Oct 19, 2020 at 15:12
  • $\begingroup$ I've added what works for me. There's a lot of good info in the post so don't want to copy it all here. $\endgroup$
    – mstreffo
    Oct 21, 2020 at 9:14
  • 1
    $\begingroup$ As the quoted text notes - turning off Clamp Overlap isn't the best solution. If you watch the video the presenter explains why the problem occurs in the first place - overlapping edges (or in my case edges that were very close to each other which I'd actually created earlier with the Bevel tool - ctrl-B - rather than the modifier). Understanding how such edges constrain what the Bevel modifier allowed me to avoid the issue in the first place (i.e. don't create overlapping or very close edges if you're planning to use the Bevel modifier). There's further useful info in the video. $\endgroup$ Mar 24 at 17:45
2
$\begingroup$

Manually select edges you want to bevel. Press W and select Bevel. Press T to open the Tools panel and on the bottom you will see different options for the bevel type.

Try selecting Width, it should work with your model type.

$\endgroup$
1
$\begingroup$

I found running a limited dissolve on the model in edit mode fixes the topology problem left by booleans. Going back to object mode should reveal that your bevel modifier is having an effect.

$\endgroup$
1
$\begingroup$

Bevel might not work in cases where the normals of the object is not correct. Recalculate normals with Shift+N.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.