1
$\begingroup$

My paint strokes get messed up, as I paint different parts of the gun. I only did three strokes, all three continuous. This only happens when I paint the model, not the UV map. The UV map has no problems, I can go to the parts with my brush and it will look high-res (Paint brush) although if I switch back to the model some parts of the model get painted with much lower quality compared to the other polygons.

Picture of my paint strokes,3 different colors.

$\endgroup$
  • $\begingroup$ Do you have overlaing faces? That looks an awful lot like Z fighting, where two overlapping faces 'fight ' for the ability to display pixels in view. $\endgroup$ – Craig D Jones Jul 11 '17 at 7:12
  • $\begingroup$ By overlaying, do you mean overlapping? The mesh might be duplicated because when I re-opened the mesh today it was duplicated. Although I did get the very original one, a non triangulated version of it unlike the one above. I then fixed the duplication from that one and triangulated it, with a modifier but I still had the issue happenning. $\endgroup$ – brolyleman Jul 13 '17 at 9:43
  • $\begingroup$ Can you try painting on a copy of the original non-triangulated one and see if the paint still breaks up? $\endgroup$ – Craig D Jones Jul 13 '17 at 20:33
  • $\begingroup$ MMmm.. I deleted the duplicated file, which was the original one, the before triangulated one. But I do remember having the same problem, even before applying a modifier. $\endgroup$ – brolyleman Jul 15 '17 at 19:47
  • $\begingroup$ And does the problem persist in a generic file with a default cube, same settings? If not, then it is the geometry or the uv unwrap at fault. $\endgroup$ – Craig D Jones Jul 16 '17 at 0:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.