1
$\begingroup$

I'm modeling a complex object,i did the high and low poly versions of this object and now i'm going to bake the normal maps ,but i've got a problem. I Split this object in a couple pieces,then i joined them together. I did for the lowpoly version, some normals got inverted, so i went to Edit mode>Control+N and it got fixed. The high poly version got those inverted normals aswell when i joined the pieces, however when i try to Edit mode>Control+N it crashes the whole PC because it has to many quads. I have a quite good PC for modelling (Core I5 3470/ GTX 760 / 12GB RAM)

I was wondering if there any way to fix the normals without getting into edit mode. Can you guys please help me? Thank you in advance

$\endgroup$
  • $\begingroup$ I don't think edit mode is what's crashing your PC. It's because you're trying to perform an operation on probably millions of tris. If you can enter Edit mode, You could resplit the object by selection using P and then fix the normals of each part. In the future, though, I would suggest using the Subdivision Surface modifier and NOT applying it. That way it gets applied dynamically only when you go to render. $\endgroup$ – bertmoog Jul 10 '17 at 22:44
  • $\begingroup$ It makes sense, but i'm going to bake the normals and stuff. Aren't they supposed to be applied first and join the objects together? $\endgroup$ – Imkls Jul 11 '17 at 0:13
  • $\begingroup$ So you're saying that even though the normals are correct in the individual parts, when you join them they face the wrong way? I would try LukeD's answer and see if that addon does anything different than doing it in edit mode. Please write back and confirm it worked. $\endgroup$ – bertmoog Jul 11 '17 at 0:24
  • 1
    $\begingroup$ Yes, the normals are right individually, but when i'm going to join them, some objects got their normals flipped, i don't know why this happen,but isn't the first time. I Tried LukeD's suggestion and it worked REALLY good and fast. But thank you for trying to help me, it was helpful. $\endgroup$ – Imkls Jul 11 '17 at 0:30
  • $\begingroup$ Very glad you got it working, thanks for letting me know. $\endgroup$ – bertmoog Jul 11 '17 at 1:09
2
$\begingroup$

As far as I think that @bertmoog could be right I will try to answer your question and propose Add-on called Flippist from Alexey Khlystov.

Flippist

  1. Download Add-on from link above and install/enable it as usual.
  2. Select one (or multiple) object.
  3. Hit Spacebar, then type Flippist.
  4. You can change settings by pressing F6 or in Tool Shelf.
$\endgroup$
  • $\begingroup$ I Liked this addon and it quickly fixed the normals. Thank you for the suggestion. $\endgroup$ – Imkls Jul 11 '17 at 0:23
  • $\begingroup$ @Imkls great to know, I've used this Add-on once or twice but for other purposes (multiple small objects). Kudos to Alexey Khlystov for such a great thing. $\endgroup$ – cgslav Jul 11 '17 at 0:36
0
$\begingroup$

You could try to do the same action you're doing right now, but from the console. And be sure to switch back to object mode at the end. Maybe then it wont crash, because blender doesn't need to draw all those faces.

$\endgroup$
  • $\begingroup$ It's a cool tip friend, i'll use it. $\endgroup$ – Imkls Jul 11 '17 at 0:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.