0
$\begingroup$

In trying to simulate a first person camera in the Blender Game Engine, I have hit a snag.

Kindly open the attached blend file and hit P to run a (very simple) demo of a first person camera (sitting atop a red cube moving across a deformed plane).

You will see that the textures of the plane (upon which a small cube is moving) shake and tremble a bit before settling down (?) every time the cube is moved.

W and S move the cube forth and back, the left and right cursor keys turn the cube.

If I try to run the test game from another view (not through the camera), there is no trembling of the texture of the plane. The problem only appears when I hit number pad zero to enter camera view and then hit P to run the game engine.

Can you help me correct this problem?

$\endgroup$
1
$\begingroup$

I suggest to use UV-Mapping (Properties / Texture / Mapping / Coordinates). It indeed means you need to setup UV-Coordinates beforehand.

There is an additional flickering that comes from shadows. I suggest to have a look at the shadow settings too.

$\endgroup$
  • $\begingroup$ Thank you very much as well! UN unwrapping the plane solved the texture problem, even when the camera was rotated at 90 degrees! I did see the problem with the shadows flickering too, but I am not sure how to tinker with shadow settings. In the render properties panel of the BGE, under GSLS, I can only turn shadows on or off. Should I play with the settings in the texture panel? Your further help would be appreciated. $\endgroup$ – John Paravantis Jul 10 '17 at 5:33
  • $\begingroup$ There is less flickering when I select variance rather than simple buffer type in the shadows section of the Sun properties panel, but I am not sure what I should change beyond that. $\endgroup$ – John Paravantis Jul 10 '17 at 5:46
  • $\begingroup$ I'm glad to help you. I can't tell about the shadows (I just switched them off and the flickering disappeared). You might post a separate question regarding shadows. $\endgroup$ – Monster Jul 10 '17 at 9:07
1
$\begingroup$

This is a really strange issue and I was able to replicate it with different textures and objects. I don't know why it happens but if you want to fix it rotate the camera a little bit on the X Axis. Just select the camera, press R then X. It looks like the problem only appears when the rotation is 90°.

$\endgroup$
  • $\begingroup$ Thank you very much! Rotating the camera to a value different than 90 degrees, e.g. 91 degrees, solved the problem! $\endgroup$ – John Paravantis Jul 10 '17 at 5:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.