I'm following this tutorial and I have applied a material to the body mesh and when I apply the material to the faces to the side of the mesh, I can see the top/bottom material is showing on the top and bottom parts of the side faces.

This is the rendered view:

enter image description here https://i.sstatic.net/J9YUL.png

and this is the wireframe showing the selected faces which the side material is applied to: enter image description here https://i.sstatic.net/mD2XI.png

I'm not sure why this is happening, can anyone advise? Thanks

  • 2
    $\begingroup$ As there are some modifiers on the object, could it be that there is Subsurf? $\endgroup$
    – Mr Zak
    Commented Jul 9, 2017 at 14:53
  • $\begingroup$ Yes there is a subsurf modifier active on the mesh. $\endgroup$
    – SmartSolid
    Commented Jul 9, 2017 at 14:58
  • $\begingroup$ Not sure if its the best way to go but I applied the modifier and then dissolved all the unecessary horizontal edges on the body sides and reapplied the material. Looks fine now imgur.com/EQrVrG3.png . Thanks for the suggestion. $\endgroup$
    – SmartSolid
    Commented Jul 9, 2017 at 15:21
  • $\begingroup$ The white line is trim geometry (its part of the tutorial steps) $\endgroup$
    – SmartSolid
    Commented Jul 9, 2017 at 15:59

1 Answer 1


You need more geometry. The subsurf modifier works by interpolation, meaning that is subdividing the geometry, the boundaries for materials are also interpolated. On the sides of the guitar you need to add supporting loops, those will help you define the edges for the material as well.

As an example of the issue, this cylinder has two materials, one for the top and bottom faces, and one for the sides. The subsurf modifier interpolates mapping of the materials clearly. Adding supporting loops will fis the mapping error:

enter image description here

  • $\begingroup$ Thanks for the example, I've tested it and get the same results as you've displayed. I've also found selecting the existing top and bottom edge loops of the mesh sides and setting their mean crease value to 1.0 also corrects the material's boundary position. $\endgroup$
    – SmartSolid
    Commented Jul 9, 2017 at 16:19
  • $\begingroup$ @KnightFallz indeed setting the crease value will have the same effect: is controlling how the subsurf modifier interpolates the geometry. $\endgroup$
    – user1853
    Commented Jul 9, 2017 at 16:38

Not the answer you're looking for? Browse other questions tagged .