0
$\begingroup$

I'm trying to make a 2D animation in Blender. I created some vector graphics in Inkscape, exported it to PNG and then imported as a plane to Blender, with settings: Shadeless, Z transparent, Alpha Premultiplied. Sadly I get an image with a gray edge that is visible when images overlap Images in Blender

The images are perfect in Unity though: enter image description here

What may cause such a problem happening? And how to get rid of it? Thanks in advance

$\endgroup$
5
  • 1
    $\begingroup$ Is that grey edge present if planes are rendered? Material shading is an approximation which got better but still doesn't always show the same as rendered (would be also great to see both planes on the background of a color other than grey). Also some images of material node setup would be nice. $\endgroup$
    – Mr Zak
    Jul 9, 2017 at 12:22
  • $\begingroup$ This is related to the Clip Alpha setting in the System preferences, check the answer by gandalf3: blender.stackexchange.com/questions/1625/… $\endgroup$ Jul 9, 2017 at 15:07
  • $\begingroup$ The grey edge disappears when rendered, to be replaced by a red one. Less, but still visible. Additionally there's a white edge around images of the same colour, the same in both rendered and not rendered.ibb.co/mf3usv Setting the Clip Alpha to around 0.7 made the grey edge significantly less visible, while pixelizing the image as well, but I guess it's a fair price. But it doesn't affect the red and white one when it's rendered. $\endgroup$
    – Krzysiek
    Jul 9, 2017 at 15:43
  • $\begingroup$ I'm afraid I'm not sure what you mean by "material node setup", I'm too big a noob for that. Is that what you meant? ibb.co/ctw5Xv $\endgroup$
    – Krzysiek
    Jul 9, 2017 at 15:58
  • $\begingroup$ You are using Blender Internal and, given that screenshot, you are using a regular Material, not nodes. He probably assumed you were using Cycles. $\endgroup$ Jul 9, 2017 at 16:02

0

You must log in to answer this question.

Browse other questions tagged .